Pwn20wnd just got done updating the unc0ver jailbreak tool with support for the new ‘Sock Puppet’ exploit by @NedWilliamson with support for firmware versions up to iOS 12.2, and as it would seem, the Electra team isn’t too far behind.

In a series of Tweets shared just this afternoon, the Electra Team revealed that it would soon update the iOS 12-centric Chimera jailbreak tool with support for the new ‘Sock Puppet’ exploit:

From what we can gather, Chimera’s upcoming support for the Sock Puppet exploit will exclude A12(X) devices, much like unc0ver; instead, it will focus primarily on supporting A7-A11 devices. A12(X) device support could eventually be added in the future, but that’s not set in stone.

As of a couple hours ago, the Electra Team said that they were “testing on iOS 12.2” and that an “update (would) be released shortly.” Unfortunately, that’s all we have as far as an ETA is concerned at the time of this writing, but we expect that it could launch tonight, or sometime this week at the very latest.

Update: CoolStar of the Electra Team has purportedly started testing the updated Chimera jailbreak tool for iOS 12.2 internally, but has purportedly stumbled upon an error with iPhone 7 handsets. He has advised the community to stand by as the team works on this issue:

With both significant jailbreak tools picking up support for iOS 12.1.3-12.2, which one are you more likely to use? Let us know in the comments section below.