Speaking of unlocking the iPhone, MuscleNerd just confirmed that an iOS 5 compatibility update to the unlock tool will be released tomorrow, after the planned MobileSubstrate update.

Of course, UltraSn0w will only work for 01.59.00, 04.26.08, 05.11.07, 05.12.01, 05.13.04, and 06.15.00 basebands. If your baseband is different from these, you will not be able to use UltraSn0w to unlock until the Team figures out a new exploit, which may take a while…

In order to use UltraSn0w for iOS 5, you will first need to upgrade to iOS 5 while preserving the baseband. This can be done using the latest version of RedSn0w — see our detailed RedSn0w tutorial.

Once you are on iOS 5 with a preserved baseband, you’ll simply need to install UltraSn0w from Cydia.

As usual, we’ll let you know as soon as UltraSn0w is updated. Stay tuned!