How to jailbreak iOS 5.1 with Redsn0w 0.9.10b6

By , Mar 8, 2012

iOS 5.1 has finally dropped, and for the most part we totally recommend staying away from the update if you care anything about your jailbreak, as does the iPhone Dev Team.

That being said, for those with older A4 devices, it is possible to enjoy a tethered jailbreak on iOS 5.1 and still downgrade back to previous firmwares if you have your SHSH blobs for those firmwares.

With A5 devices like the iPad 2, and the iPhone 4S, it is impossible at the moment to downgrade to any older iOS 5.x firmware, even if you have your SHSH blobs saved. So don’t upgrade to 5.1, especially if you care about your iPhone 4S jailbreak.

If you have an iPhone 4, iPod touch, iPhone 3GS, or original iPad, then check inside for a tutorial on how to perform a tethered jailbreak on iOS 5.1…

Step 1: Download RedSn0w 0.9.10b6 from our downloads page and run it.

Step 2: Place your iPhone 4, or iPod touch, etc. into DFU mode.

Step 3: Click jailbreak on RedSnow, and it will go through the process of finding the necessary firmware. It will then ask you to install Cydia, make sure that is selected and click next.

Step 4: You should see a lot of scrolling text on your device, and eventually you will be back to your Home screen. You will see a Cydia icon but it will be white. That is because you have to perform a tethered boot.

Step 5: Place your iPhone 4, or iPod touch, etc. back into DFU mode.

Step 6: Click back on redSn0w and select Just boot. This will perform a tethered boot, and once your device returns to its Home screen, you will see a usable Cydia app icon. Open Cydia, and enjoy your jailbreak.

Note: Each time you reboot your device, you will have to perform steps 5 and 6 again to perform a tethered boot.

Again, we can’t stress enough how important it is to stay away from iOS 5.1 if you care at all about your iPhone 4S jailbreak. iPad 2 owners will also be impacted, so don’t update either, though, you can still downgrade to older 4.x firmware if you have your blobs for iOS 4.x.

Are you going to jailbreak your iPhone 4, iPod touch (4th generation), etc?

  • Share:
  • Follow:
  • http://www.facebook.com/joneilravacio Joneil-Sheila Ravacio

    thanks for this again! wew without jailbreak ios is so boring! (its just my opinion)

  • http://www.facebook.com/profile.php?id=100002438373102 Praveen Kumar

    I am using 3GS iphone 4.1 version already jail broken. Now i am planning to upgrade from 4.1 version to 5.1 Or 5.0.1 version. how can i do it?
    My laptop: win 7, 64 bit.
    I am waiting for ur reply.

    Praveen

  • kevin chiong

    Hi, im new here, i currently is on iOS 5.1, i wish to downgrade, but i am nt sure i have the SHSH blob, so what should i do?

  • Aurora Valdez

    is it safe for the iphone 4? Im nervous what if it locks my IPhone4? (gulp)

  • Aurora Valdez

    is it safe? will it lock my phone? (gulp)

  • Kholika alki paro

    halo, my iphone 4g / ios 5.0.1 (9A405) Unthetered, after i was following process of jailbreak and follow the instruction, so my jailbreak process finished, but when i was checking my iphone, my iphone’s still like in the first time and not change anything. Maybe someone know, what’s wrong with my iphone and resolve my problem, thank you :)

  • Ronald Payne

    if i have verizon service on my iPhone will that interfere with my service if i jailbreak it ?

  • Patrick Preciado

    i accidentally updated my iphone to iOS 5.1 and it was jailbroken. now what do i do? :/

  • micoandmojo

    what if your iphone3gs is on the fatoray settings and trys to boot up but keeps saying that there is no sim on itunes, and on the phone it says server down try again what can you do then!

  • TOMMY CHANGAS

    can u do this with iphone 3gs with 5.1.1 version

  • Junior

    i am having problems accessing the iphone home user interface of my i phone 4s, it just keeps telling me the sim card inserted cannot activate my iphone. its locked to a network in Switzerland. what do you suggest i do please?

  • Ana

    Hi. I would like to know if there’s an untethered jailbreak for my old 3gs running 5.1.
    Thanks

  • Seph

    I have done the jailbreak but i cant open cidya or safari and when i put iphone in DFU mode and open redsnow it does not say “just boot” Help!

  • http://www.facebook.com/marcos.pereztorres1 Marcos SocRam Ken

    hey i cant do it cause it sed that incomplit libraries! what can i do to fix this???
    PLEASE HELP ME!

  • a generic user

    almost a year later, there is still not untethered ios 5.1 jailbreak. (yes, i’m aware of ios 5.1.1)