How to Unlock your iPhone 4.3.3 with UltraSn0w

By , May 6, 2011

Thanks to the hard work of the iPhone Dev Team, the UltraSn0w unlock for iPhone has been updated to play well with iOS 4.3.3. As mentioned in our previous post about UltraSn0w, this will only work with iPhone 4 baseband 1.59.00, and iPhone 3G/3GS basebands 4.26.08, 5.11.07, 5.12.01, 5.13.04, and 6.15.00.

If your baseband is different from these, then you can’t unlock for the time being. If your baseband matches one of those above but you are on an older firmware, use PwnageTool to update while preserving the baseband.

In this tutorial, we will show you how to unlock your iPhone 4.3.3 using UltraSn0w…

Step 1: Make sure your baseband matches any of the basebands listed above. If it doesn’t, you can’t unlock. If it does, you may update your iPhone to 4.3.3 while preserving the baseband using PwnageTool. Note that you don’t have to update to 4.3.3. If for example you are still on iOS 4.1, you may stay there and still use UltraSn0w.

Step 2: Make sure your iPhone is jailbroken. The easiest way is to use RedSn0w, although it can be tricky as you might accidentally update your baseband. Which is why I suggest you use PwnageTool instead. PwnageTool will not update your baseband.

Step 3: After jailbreaking, go to Cydia and search for “UltraSn0w”. Download and install the app, then reboot your iPhone.

That’s it. Your iPhone should now be unlocked.

If you use T-Mobile, make sure to turn 3G OFF in your iPhone settings.

  • Share:
  • Follow:
  • Dj

    I think apple will let u use itunes to install 4.1. I do know that to do anything else it needs to be previouslly jailbroken. I would just use the latest redsnow to jailbreak. If your baseband is unlockable as it is do it. If u have to baseband flash DO NOT DO IT. I have had good, yet mixed success myself with baseband 16.15.00

  • 2

    How is the downloading and installation of the jailbreak and unlock software done, with iTunes?
    Can it be done on Windows or Linux?

    • Google_it_dood

      U don’t really use iTunes. U just get fw4.1 install that with option restore…let it work…then ger redsnow, and do as it says..villa easy as that. I learned everything I know by spending countless un payed hours reading…not to be a dick but try it!

    • Google_it_dood

      U don’t really use iTunes. U just get fw4.1 install that with option restore…let it work…then ger redsnow, and do as it says..villa easy as that. I learned everything I know by spending countless un payed hours reading…not to be a d#*% but try it!

  • Paul

    Hi everyone,

    Still no news on how to downgrade from 06.15.00?
    Or how to fix GPS signal?
    Tkx

    Paulo

    3GS 32GB JAILBREAK
    4.3.3 – 06.15.00

  • Edgar

    I have 3GS 4.3.3 6.15.00 bb and it’s jailbroken but I cant unlock it using ultrasnow. Help :( please help

    • Google_it_dood

      Me too! I’ve combed google throughly and have re installed. There is an ultraslow for iPad baseband at heaveniphone.com/Cydia (check that may be off a character or two) I tried that and no luck. Also read to use ultra snow 1.2 for iPad baseband that did not help me either. I think it’s the jailbreak myself. I’m just hoping and preying lolp for the promised baseband downgrad

  • http://download-mobile-software.blogspot.com/ free unloack jailbreak iphone

    hawe free unloack jailbreak free …

  • http://www.facebook.com/adi688 Ch Yasir

    i upgrade my iphone 4 to 5.0.1 prserving baseband(1.59.00)
    Now i want to downgrade my iphone to 4.3.3 i have my SHSH blobs saved
    this can downgrade can preserve my baseband??
    because i want basband 1.59.00 to unlock with ultrasn0w

  • Anonymous

    Did anyone get their iPhone, with baseband 04.10.01 and version 4.3..3 unlocked?

  • http://www.facebook.com/nivlaool Loo Nivla

    I’m using 3gs with baseband 6.15.00 and installed ultraslow but still can’t detect sim

  • Anonymous

    Hi,

    I have an iPhone 4 with iOS 4.3.5. and a baseband of 04.10.01, which I jail broke with RedSn0w. I don´t know if the baseline upgraded after the jailbreak, as I didn´t remember to check the baseband before doing it :( If it is not possible to unlock it with UltraSn0w, is there other way I can do it?

    Thanks!

  • Anonymous

    Hi,

    I have an iPhone 4 with iOS 4.3.5. and a baseband of 04.10.01, which I jail broke with RedSn0w. I don´t know if the baseline upgraded after the jailbreak, as I didn´t remember to check the baseband before doing it :( If it is not possible to unlock it with UltraSn0w, is there other way I can do it?

    Thanks!

  • petlan

    My bro has an iPhone 4 with iOS 4.3.3 and in the settings>general>about>modem firmware says it’s some 10.something.something.something, but he STILL has it unlocked since he uses a T-mobile SIM.

    Although info’s you might need to know that we live in Hungary so don’ know if T-mobile is allowed there, and also the unlock was made by someone else for a nice sum of money so maybe there’s a different way or a hardware crack?

    • petlan

      Make that 4.10.something. :P

  • http://www.facebook.com/lh.zsolt Szilagyi Zsolt

    Hy everyone, can somebody help me unlock my iPhone 4 with baseband 04.10.01 on version 4.3.3 (8J2). I’m using gevey for the moment but in Romania the signal is still very weak in some places and i lose signal very often. Thx.

  • Zsolt Szilagyi

    Hy everyone, can somebody help me unlock my iPhone 4 with baseband 04.10.01 on version 4.3.3 (8J2). I’m using gevey for the moment but in Romania the signal is still very weak in some places and i lose signal very often. Thx.

  • lamin kebbeh

    mistake i set my phone in factory setting, no ios please help me, am in Gambia west Africa, so i want to use my phone now.