Looking to unlock your iPhone running iOS 4.1? We’ve got some good news and some bad news for you… Let’s start with the bad news, shall we?

The bad news is that if you’ve already updated your iPhone to iOS 4.1, you will not be able to unlock it, at least for the time being. MuscleNerd confirmed that UltraSn0w will not work on any iOS 4.1 baseband and that you cannot downgrade to a previous version.

And now for the good news…

The good news is that if you haven’t updated your iPhone to iOS 4.1, the Dev Team will be releasing an update to their PwnageTool jailbreak that will allow you to upgrade to iOS 4.1 while preserving your baseband, thus being able to use UltraSn0w to unlock.

In short, if you’re already on iOS 4.1, you’re screwed. If you’re on a previous firmware, you’re good as long as you use PwnageTool to jailbreak.

I’m sure the Dev Team will be working on a 4.1 unlock in the near future but I wouldn’t expect to see anything released before iOS 4.2 comes out in November. At that time, maybe (and I’m saying “maybe”) 4.2 won’t update the baseband and we’ll be able to use a potential unlock. I don’t have much hopes for that though.