The Dev Team released RedSn0w 0.9.6 Beta 1 a few hours ago. This latest update to the popular jailbreak tool will only work with the iPhone 3G iOS 4.1 and iPod Touch 2G.

According to the Dev Team, RedSn0w 0.9.6 Beta 1 uses the same pwnage2 DFU-mode exploit that has been around for a couple years. It does not use the SHAtter exploit discovered by pod2g, so there is nothing really new here…

If you want to use UltraSn0w to unlock your iPhone later on, then stay away from RedSn0w and wait for PwnageTool. To use RedSn0w to jailbreak iOS 4.1, you need to already be on 4.1. If you update to the latest firmware though, you may lose the ability to unlock, possibly forever.

Important: if your iPod Touch 2G is an MC model, your jailbreak will be tethered. Best thing to do might be to downgrade to a previous iOS and jailbreak using Spirit or JailbreakMe.

So far, this version is Mac only. A Windows version is in the works and should be available soon, so stay tuned.

And here is the RedSn0w 0.9.6 tutorial