iOS 4.3 Will Not Be Compatible With All iDevices

By , Mar 5, 2011

We’ve gotten questions from readers asking if iOS 4.3 will be compatible with all iDevices. Sadly, the answer is no. The public release of iOS 4.3 that Apple announced at their iPad 2 event will only work on certain iDevice generations.

Most notably, 4.3 will not be installable on the Verizon iPhone. Because the Verizon iPhone runs on a different baseband and has different bugs to fix, Apple has to release a separate 4.3 build for that device. (Which they haven’t announced yet.)

Hopefully your iDevice isn’t on the 4.3 incompatibility list…

Apple is continually innovating, and there always comes that harsh moment when they drop support for their older devices. The iPhone 3G and 1st-2nd gen iPod Touch will not be compatible with iOS 4.3. If you’ve got a 3GS or iPhone 4, you’ll be fine.

The Verizon iPhone currently runs 4.2.6, and it is unclear as to when Apple will push a 4.3 update that’s compatible with the CDMA baseband.

We’ll let you know when 4.3 is headed to the Verizon iPhone. Remember, iOS 4.3 will be available for download in iTunes on March 11th for compatible devices.

[via TUAW]

  • Share:
  • Follow:
  • http://www.newitworld.com new it world

    You are telling truth i think

  • http://www.ipadbeans.com Will

    There goes my second gen touch… Ah well,at least I still have my 3GS.

  • appletiser

    as of yet i’ve not been too fussed with new releases, 4.0.1 still serves me and my jailbroken 3gs fine thank you :)

  • tyrtey3wtyh

    Too bad. I have a 2g iTouch and I didn’t know it was going to last this short, I only got a year and one month cuz I have an MC-model and I bought it January.

    BTW: I hate you Apple, my iPod should have been third generation.

    • AT0M!X

      Yea, Apple should change our devices that comes from ~1 year for a iPod touch 4!

  • AT0M!X

    I saw 1st 2nd gen iPod touch.
    This means the iPod touch 2 with the old iBoot rom will not be able to have it?
    This means that the version with the new iBoot rom will be fine for the update? :D
    I have the new so i think that i will be fine for the 4.3 update in this article but i’m not sure.
    Anyways, if we can’t, the whited00r team gona try to make a 4.3 like iOS based on 4.2.1 i think… :D

  • vibe

    Yea awsome, my 3G sux, but I’ll never sell it saving money for iPad, 1st gen of course, thank god there isn’t an iPhone nano lol

  • Pam

    Figures. At least I only have to keep my 3G until June.

    • Z

      same here …. i cant wait until the iphone 5 is out along with ios 5

      • leart

        And it come out an iPhone 4S ;)

  • http://www.photoprose.org horqua

    I have a 3G. So much for Apple’s forward thinking. More like typical planned obsolescence. I’m not sure it’s worth buying Apple iPhones when they’re going to leave you out in the cold if you’re not willing to pay them their annual extortion fee. 3Gs will be next.

  • Sean

    I have the “Third Gen” 8GB touch, and it’s incompatible. For anyone that has a supposedly 3rd gen iPod Touch, if it’s 8 GB, it’s not actually 3rd Gen, and it’s incompatible with 4.3 (also kinda hard to jailbreak)

  • Jay

    Jailbroken ipod touch 2G has served me well, and will continue to serve me until I get an android. Apple, you have screwed me over one last time

  • Lolo

    You are fools if you think that you are ok with you 3rd generation ipod touch. Give it time and all of you will see how your device gets old and you cannot install any more apps in a very near future, as it happens to me with my 1st gen. The problem is that we don’t fight against this kind of abuse from apple. I have my 1st gen since december 2008, IT IS LESS THAN 3 YEARS OLD!!! and I can barely use it anymore because I cannot update it, not even paying for it!! Do you think that is normal and fair? I think it is not. It is bullshit.
    From now on, I WILL NEVER BUY ANY OTHE APPLE PRODUCT

  • Lolo

    You are fools if you think you are ok with you 3rd gen itouch. Give it time and all of you’ll see how your device gets old and you cannot install any more apps in a very near future, as it happens to me with my 1st gen. The problem is that we don’t fight against this kind of abuse from apple. I have my 1st gen since december 2008, IT IS LESS THAN 3 YEARS OLD! and I can barely use it anymore cause I cannot update it,even paying for it! Do you think that is normal and fair? I think it is not. It is bullshit.
    From now on, I WILL NEVER BUY ANY OTHE APPLE PRODUCT

  • Lolo

    You are fools if you think you are ok with you 3rd gen itouch. Give it time and all of you’ll see how soon your device gets old and you cannot install any more apps, as it happens to me with my 1st gen. The problem is that we don’t fight against this kind of abuse from apple. I have my 1st gen since december 2008, IT IS LESS THAN 3 YEARS OLD! and I can barely use it anymore cause I cannot update it,even paying for it! Do you think that is normal and fair? I think it is not. It is bullshit.
    From now on, I WILL NEVER BUY ANY OTHE APPLE PRODUCT