RedSn0w 0.9.10b7 released for Mac and Windows

By , Apr 20, 2012

A new version of the RedSn0w jailbreak tool was released today, bringing us a nice assortment of new features, and hinting at an even greater things to come…

Beta 7 of RedSn0w 0.9.10 contains a nice assortment of new useful features, including the iPhone 4S and iPad 2 Corona A5 untethered jailbreak for iOS 5.0.1.

Check inside for a full rundown of what’s new, and what’s new to come…

Along with the Corona untether implememntation, the newest version of RedSn0w also includes the following:

  • It can also re-install the Corona jailbreak for those who accidentally uninstall it.
  • When stitching an IPSW, RedSn0w now pulls your SHSH blobs from Cydia.
  • More verbose device info: i.e. RedSn0w will tell you if your iPhone3G has the vulnerable baseband boot loader, old exploitable bootrom, etc.

Even more exciting is what’s to come. According to the iPhone Dev Team, the next new feature will be built-in restore support, eliminating the need for iTunes to perform restores. That sounds like a much needed feature, and we can’t wait to take it for a test drive!

Head over to our downloads page to find both the respective links for both the Mac and Windows version of 0.9.10b7.

What do you think about the new RedSn0w?

  • Share:
  • Follow:
  • David Christian Elisa Dengah

    this is just great!
    does this mean that those who accidentally upgraded to iOS 5.1 would be able to downgrade to 5.0.1 using stitched IPSW?

    • http://www.facebook.com/profile.php?id=1507068701 Jorit Studer

      not yet but soon iH8sn0w is working on it ;-D

    • http://www.facebook.com/mo003akes Sultan Sa

      is downgrading a problem ..? I did downgrade from ios 5.1 to 5.0.1 without any problem …

      at the first, the itunes did pup-up a lot of error messages .. but after some researches I successfully downgrade an re-install jailbreak+Cydia on my Iphone4…

      • Anonymous

        It is still helpful to replace iTunes for restores all together. Who knows, maybe because iTunes is getting replaced (restore wise any way) maybe we will not even need SHSH any more at all. Tho I highly doubt that. Fact is of coarse an “A4″ device can downgrade no problem. Its easy as long as you have SHSH (I do it al the time). I am assuming the breakthrough mostly applies to A5 devices….Tho it is still great news for all models of iDevices I’m sure.

      • David Christian Elisa Dengah

        well it is a problem when you got an iPad 2 :)

  • http://www.facebook.com/profile.php?id=100003530234142 Peter TheMoo Cow

    RedSn0w 0.990.10b8 – New iPad/iPad 3 jailbreak, hopefully

  • http://www.facebook.com/mdhafidh Md Hafidh

    old iphone 4 can use?>

    • jose castro

      can we downgrade old iphone 4 to 5.0.1?

      • maxim stomphorst

        sure if you have you’re SHSH blobs use a youtube tutorial to see how ;)

  • http://twitter.com/TheSuperior_93 UpIn( ´Д`)y━・~~

    Will this work for iPhone 4s 5.0.1, will I lose my current jailbreak, apps, data on 5.0.1 I ask due to me losing two important stock apps mail and iMessage/messages apps. I know that a restore from iTunes causes an update and I lose jailbreak; I could wait for a new release but I rather find a fix to this any help.

    • Anonymous

      as long as you uncheck “install Cydia” you should be fine.

      • http://twitter.com/TheSuperior_93 UpIn( ´Д`)y━・~~

        So to be sure I won’t lose my apps and data

      • Anonymous

        correct. it will just go over the coding and other jailbreak data and will NOT overwrite Cydia

      • http://twitter.com/TheSuperior_93 UpIn( ´Д`)y━・~~

        It just begins to load and gives me a popup saying the device is already jailbroken and where I’d the install cydia option

    • http://www.facebook.com/mattpet Matt Dowdy

      Have you tried settings, general, reset, reset home screen layout? That happened to me once (just the mail app though) and it came back

      • http://twitter.com/TheSuperior_93 UpIn( ´Д`)y━・~~

        Yes tried and it failed

  • http://www.facebook.com/jacer.lee Jacer Lee

    I am kinda confused, is this also an update to the absinthe jb users?

  • http://www.facebook.com/profile.php?id=1507068701 Jorit Studer

    nice and haappy 4/20 to u guys :D keep rollin’

    • mordechai eliyahu

      today is national pot day enjoy people, keep trolling while ur high :)

  • http://twitter.com/Sirifl0w Sirifl0w

    Can we downgrade our iPad 2 and iPhone 4s from 5.1 to 5.0.1 now then by using saved shsh blobs and stitching etc..?

    • Mordechai Eliyahu

      nope, i wish i can also

  • Mordechai Eliyahu

    i jailbroke my iphone 4s on version 5.0.1 and i needed to restore it to put my service on it and when i restored my iphone it got upgraded to 5.1 that sucks

    • http://twitter.com/TheSuperior_93 UpIn( ´Д`)y━・~~

      If you used iTunes that’ll always happen restore plus upgrade or did you run the jailbreak through redsn0w

      • mordechai eliyahu

        i jailbroke threw absinthe it was a iphone 4s 5.0.1 was there a way to restore it without upgrading?

  • Dan

    the new restore feature is great news, can’t wait for it to be implemented

  • http://twitter.com/TheSuperior_93 UpIn( ´Д`)y━・~~

    I don’t see the option for uncheck cydia install

  • http://twitter.com/amad_ahmed01 Amad

    Redsnow does so many things now a days, i’m hoping the next update will do my job for me so i dont have to work. Make it happen iphone dev team.

  • Anonymous

    ummmm…. is there a jailbreak for ipad3 yet?? no?? booo

  • http://twitter.com/G__ROCKS_ Gerson Castañeda

    does this update mean i don’t have to use the absinthe jailbreak??

  • Leo Sack

    The 4S and iPad 2 jailbreak was implemented in the last version of RedSn0w. RedSn0w b9.10.6b

  • Anonymous

    Hmmmm….. I wonder who’s fault it is that many people uninstalled Corona : ) Thank You Jeff no worries reinstalled using ifile an the correct deb file

  • Jude Johnpeter

    cant save SHSH blobs when using an iPhone 4S

  • http://twitter.com/mizter_popo Rizky Ardi Nugroho

    How to upgrade the jailbroken iphone with this new update of redsnow?

  • Krishna Sagar

    I think we had enough of betas already! I want the iPad 3 Jailbreak by RedSn0w 1.0 not 0.9.10b8… :)

  • http://twitter.com/hamoudeh mohammad khalil

    what is vpn password?

  • http://twitter.com/hamoudeh mohammad khalil

    hi
    i am trying to jailbreak my 4s with redsn0w 10b7 but it keep asking me ” enter your password for the vpn account “pod2g” proposal authentication _method.
    any idea plez?

    • Arkady Tveretinov

      just click next

      • http://twitter.com/hamoudeh mohammad khalil

        when i click next it tells me profile failed to install

  • http://www.facebook.com/people/Peedee-Fenelus/595401750 Peedee Fenelus

    hi i have a ip4s running on ios 5.0.1 with the cydia corona 5.0.1 untether jailbreak can i run the redsnow 0.9.10b7 over it or do i have to uninstall the corona from cydia first. any help guys

  • http://www.facebook.com/profile.php?id=100000707133179 Asmi Wt

    got Iphone 4s (A5) ios 5.1 , will this work, or i have to wait till the jailbreak community release the jailbreak for A5 devices? and i was wondering since “pod2g” the security expert had already done jailbreak on his Ipad 3 (A5) Device and Iphone 4 , when is he going to release it or his waiting for the new ios 6 ????