The Dev Team has released RedSn0w beta 9 for Mac and Windows. The jailbreak tool has been updated to offer full support for users that are stuck on iOS 5.0.1.

Like all previous releases for iOS 5, this jailbreak is a tethered one. The Chronic Dev Team’s pod2g is actively working on an untethered jailbreak for iOS 5.

More information on the latest RedSn0w release:

The holiday season is almost here (Happy Holidays!) so we realize everyone is busy (especially @pod2g!).  And even though we always recommend that jailbreakers stay where they are until a new untethered JB comes out, that’s not always possible.  So we’ve updated redsn0w for those who may have found themselves at iOS 5.0.1, and added some other useful features too:

  • native support for 5.0.1 (no need to point redsn0w at 5.0 IPSW or use command-line args).  Support automatically extends to all of redsn0w’s various functions: “Jailbreak”, “Just boot”, “Fetch blobs”, “Stitch blobs”, “Recovery Fix”
  • iBooks fixed in 5.0 and 5.0.1.  This is a targeted fix that doesn’t remove entire sandbox mechanism.  5.x users already using redsn0w “Just Boot” can just use the new version without redoing entire jailbreak again
  • 3GS old-bootrom owners can now create custom IPSWs without blobs
  • ultrasn0w compatability update (i.e. same baseband requirements) for 5.0.1 will be available on Cydia Monday
  • support for newer 8GB iPhone4 (which until now had problems with “Fetch blobs”).  Thanks to @JKjeepnJeff for loaning us one of these newer i4 units for testing!
  • allows Windows users (not just OS X users) to use the “Custom” button to create IPSWs without baseband updates
  • accommodates APTickets in 5.x (until next Apple countermove).  APTickets are crypto-verified before submitting to Cydia, just like the main blobs.  Cydia server support for sending back the APTickets is upcoming.  For now, use stitched IPSWs for 5.x.  Due to APTickets, stitched 5.x IPSWs now require user to start in “Pwned DFU” mode
  • Support added for stitching 4.x blobs to iPad2-GSM IPSWs.  Similar to @notcom’s TinyCFW but doesn’t require lots of RAM or a TSS-assisted restore. Won’t work for iPad2 5.x blobs (or iPhone4S at all) until a bootrom-level exploit is out
  • top line now shows whether (and where) a redsn0w update is available, or if the version being run is the latest.  Uses DNS TXT record to alleviate any concerns about snooping
  • no 5.1 beta support at this time (major apps like Cydia are not yet compatible)
  • @pod2g has been doing a great job porting his 5.x untether…check his blog for updates!
  • Owners of newer 3GS iPhones must not flash the iPad baseband.  The iPad baseband will not work on 3GS iPhones built later than 2011 week 35.

This is still a tethered jailbreak for all except old-bootrom 3GS users.

As usual, you can download the latest version of RedSn0w from our Downloads page. We have a dedicated RedSn0w page with everything you need to know about the popular jailbreak tool.

  • @Jeff
    what this mean?
    @pod2g has been doing a great job porting his 5.x untether…check his blog for updates!

    is this mean this new version have the untether Jailbreak ?

    • It’s still tethered, that message was just to show pod2g’s working on the untether.

      Ad@m

  • @Jeff
    what this mean?
    @pod2g has been doing a great job porting his 5.x untether…check his blog for updates!

    is this mean this new version have the untether Jailbreak ?

  • It couldn’t work for me and showed that “iPad 2 isn’t supported” message on RedSn0w. Anyone in here work?

    • There’s no iPad 2 jailbreak at the moment.

      Ad@m

  • It couldn’t work for me and showed that “iPad 2 isn’t supported” message on RedSn0w. Anyone in here work?

  • nice! no need pointing redsn0w to 5.0 to boot tethered 🙂

  • nice! no need pointing redsn0w to 5.0 to boot tethered 🙂

  • Major apps like Cydia aren’t supported??? Why and how would you jailbreak with this without Cydia?

    • Even Lok

      He means 5.1, not 5.0.1

    • Even Lok

      He means 5.1, not 5.0.1

  • Hey guys, I just wanna ask, will Cydia accept my PARTIAL iOS 5.0 shsh blobs? Partial means that it doesn’t have APTicket integrated, right?

    • Anonymous

      I believe so.

  • Hey guys, I just wanna ask, will Cydia accept my PARTIAL iOS 5.0 shsh blobs? Partial means that it doesn’t have APTicket integrated, right?

  • Dan

    the improvement I am looking for? Untethered.

  • So..does this mean iBooks is fixed in this version or would I still have to go through ifile and manually fix ?

    • Anonymous

      I tried it. Before the jailbreak, iBooks detected I was jailbroken.

      After, it worked perfectly. It’s fixed.

  • nate zwit

    does this work for baseband 4.11.08 or am I still stuck

  • Anonymous

    after installing installous,it ask me to reboot the device,but the apple logo get stuck,pls help

  • I just booted iphone with new version of redsnow and instaled ibooks but the app isn’t workig again. Wath shud i do? Can someone help me?