It is official! The iPhone 3GS jailbreak for OS 3.1 announced yesterday and confirmed earlier today is out, compliments of the Dev Team.

The iPhone 3GS is now supported in PwnageTool 3.1.3, assuming the phone was pwned at 3.0 or 3.0.1 – PwnageTool does not support the 3GS out of the box. If your iPhone 3GS has 3.1 preinstalled and is not Pwned then there is no tested jailbreak solution at the moment.

This means that if you updated to 3.1 or if you bought your iPhone 3GS with OS 3.1 already installed, you will not be able to jailbreak. However, if you are on a pwned version of 3.0 or 3.0.1 (either using PwnageTool, RedSn0w, or PurpleRa1n), then you are fine.

Good news for iPod Touch 2G users! PwnageTool will also support this device.

The iPod 2G is now supported in PwnageTool 3.1.3, assuming the iPod 2G was pwned at 3.0 or 3.0.1 – PwnageTool does not support the iPod 2G with 3.1 software out of the box.

PwnageTool is for Mac OS X only. There is no Windows version yet but let’s hope the Dev Team works on this in the near future.

I will be working on a tutorial and post it on the blog asap. Visit the Dev Team blog for full information on the release.

  • Marauder2222

    Use IH8sn0w for windows. Follow the directions. Will jailbreak ANY 3.1. OTB. iTunes update. Search YouTube. Ih8snow windows. 100% works.

  • Solarwind

    Marauder, are you being serious or is this a joke?

  • W7User

    if we use ih8sn0w, it means that we have to upgrade first through itunes to 3.1 right ?
    Then we wont be able to unlock am I correct ? I’m on 3.0.1 unlocked and I want to remain unlocked.

  • Cayman (Attila)

    is that means, if i have anything but 3gs, then i can put a jailbroken 3.1 to my iphone. but why is the jailbroken 3.0 isnt good? why needed 3.1? πŸ™‚

    The second thing to Marauder: this stuff can jailbreak any device with 3.1 except 3gs, right? i read about it a bit, and it seems to be true.

    So everybody is happy, windows and mac users, except who was happy to had a chance to bought a 3gs πŸ™‚ (and was so stupid like me, and messed up with the 3.1 update πŸ˜€ )

  • I suggest NOT using ih8sn0w or anything not endorsed by the Dev Team.

  • Fred

    I will tell you something and make you think about something else.

    I have done tons of JB for several people ( friends, and family members, co-workers ), now, a lot of times things are pure smooth and all is great but, there are other times that things go not as good.
    I am running a 3GS pwned with 3.0 firmware and i have everything i want in the phone the way i want ( except dropbox asking for 3.1 ).
    I AM HAPPY WITH IT. Do i need to go to 3.1 ? NO
    DO i want to go to 3.1 ? YES.

    But i am smart enough not to rush things and learn with other peoples experience, remember, there is always a chance that something will go wrong. For instance i will just let you know that a lot of people upgrading to the original apple 3.1 are experiencing really bad battery problems, and you know what, last thing i need is a JB phone that does not last on.
    My battery could be better at this point , but it is pretty good compared to some people’s phone i know, so I AM STICKING to 3.0 until i feel necessary to go to 3.1.

    Now i have to control my urge, because i really like the latest and greatest, but, i will be strong this time.

    For everybody going bananas on 3.1, good luck and bon voyage!

  • Interesting comment, Fred. I do feel the same way. I don’t think I’m going to update to 3.1 because the last thing I need right now is a worse battery…

  • Darq

    What if i have a jailbroken 3.0 iphone, and used purple rain?

    Can I use 3.0 pwnage tools on top of my purple rain? Then that would allow me to use the new 3.1 pwnage tool.

    If not.. what should I do? I used purple rain when it came out to jailbreak my phone. Do I need to restore my phone to original 3.0? or can I run pwnage tools 3.0 over purple rain?

    Thanks for any help.

  • @Darq you’re good to go, dude.

  • Darq

    @ sebastien.

    does that mean I am good to go to use the new 3.1 pwnage tools without having to do anything else?

    Thanks, I just want to make double sure before I end up with a phone I can’t use πŸ™‚

    Again, I have 3gs 3.0 firmware jailbroken with Purple rain.

  • @Darq – I confirm that you are good to use the new PwnageTool for your 3GS 3.0 previously jailbroken with PurpleRa1n

  • Darq

    Awesome thanks Sebastien πŸ™‚

    Now all I need is a Mac! lol

  • Fred

    Yes Sebastian,

    My phone right now is awesome, i have all my apps, all my settings, all my neat looking 5 rows of icons all sorted the way i like it. Do i want to lose all that ? I had a lot of work to make it like that and the only thing i would benefit right now from having 3.1 is the dropbox app. It was hard enough to turn into the 30’s, i will stay like that for now πŸ˜€

  • WOW!

    how long does it take to put a 3.1 version of REDSN0W already?!?!?! Its ridiculous, most ppl have windows, and yet we wait longer???

  • Rocco

    So if I jailbroke on 3.0 and 3.0.1 then updated to 3.1 with iTunes can I still jailbreak with new software or not.

  • Mark

    Pardon my newbness….
    Just got a new iphone (had to wait for contract to expire). I got the 3gS and went home and upgraded to 3.1
    Am I still out of luck to JB my phone?
    I read through some things but am still unsure if there is a difference between an out of box 3.1 and a manually upgraded 3.1

    Thanks for any help!

  • Bennlloyd

    @Fred and Sebastien
    I am exactly the same as you and only need 3.1 for 1 or 2 apps. My setup took me longtime too get jus right and like you guys not had any of the probs associated with iPhone (as yet,lol) battery life depletion,freeze ups,etc.. Also like you Fred the ’30’ ish thing is something I want too hold on too,lol. Don’t get me wrong I nearly did the 3.1 thing awhile ago as I have access to a mac,girlfriends, my laptop is windows, but I am restraining myself until a fully operational windows version with all the trimmings comes out,tethering etc.. I am in no rush or need to upgrade or downgrade as some say too 3.1.

  • Terrance

    I am so unlucky as i bought iphone come with preinstall OS 3.1. Still waiting for the updated ver of JB. Not like you all can chose not to upgraqde… πŸ™

  • Tilapia

    Ok so, foolish retarded me, decides to upgrade his perfectly happy jailbroken iPhone on 3.0. Worst decision ever made. Now I am on 3.1 and I been waiting for the 3.1 jailbreak to find that I STILL can’t jailbreak bc I never submitted my shsh (something like that) to cydia. What do I do?? And is there going to be a jailbreak for out of the box iPhone 3gs or ppl like me??
    Plz help! Thanks πŸ˜€

  • oneuptick

    I have a iPhone 3GS came with OS 3.0.1 installed and I have NOT jailbroken it. Can anyone offer some steps or helpful insights on jailbreaking?

  • David

    OK so I made a custom firmware upgrade using the new pwnage 3.1 tool. I then backed everything up (including Cydia installed applications using Aptbackup) and then restored the new firmware in ITunes. All went to plan, except that I couldn’t use Cydia! It kept telling me that it didn’t know what version it is so I couldn’t install Aptbackup to restore all Jailbroken Apps. Saurek acknowledges the problem and suggested it’s due to co-installation of Cydia with Icy. So I made another custom file, going into expert mode to exclude Icy. All went well again except this time, no network carrier! I couldn’t reregister no matter what I tried. Fortunately, I still had the custom 3.0 firmware so I restored with that and after another endless wait, I managed to get my 3G back to the state it was in before I started. So, a waste of time for me at the moment I’m afraid. I suggest you wait a bit longer before going for 3.1 as there seems to be a problem with the pwnage firmware builder at the moment.

  • iPhone 3GS

    David,

    3.1 pwnage doesn’t have a problem. The problem with losing the carrier is due to the fact that you are running the older BB on 3.1 instead of the newer one (that one that Apple meant for us to use). You can use Make-It-Mine to add the carrier back in if you really must have it displayed. Or, you could always update the baseband to 05.11.08 if you don’t need ultrasn0w unlock.

  • hi after upgrading to 3.1.3 in iphone 3g i get “unable to load network list” have tried creating a new ipsw with “activate” unchecked in the pwnage too please help any inputs highly appreciated

    john

  • David

    Thanks for the tip iPhone 3GS. The baseband I’m using is 04.26.08, so I guess that must be the 3.0 baseband. It could explain my carrier problem. I suppose the pwnage tool doesn’t upgrade the baseband because it disables ultrannOw’s unlocking capacity. But why then doesn’t it at least warn the user that upgrading to 3.1 using pwnage is likely to lead to carrier problems? Incidentally, with no carrier detected, I suppose I would have to resort to Make-it-Mine to get my upgrade registered anyway? Not sure how I update the baseband without unjailbreaking my phone.

  • Jo

    I am having problems jail breaking 3gs and I tried everything…I have 3.1 and how do i go to jail breaking it I tried purplera1n, yellow snow, redsn0w…can any one suggest what to do use ….I get as far as starting and I have to restore it several times…

  • Andrew

    Hey I jailbroke 3.0 with purple rain, then upgraded to 3.1 via iTunes, can I make pwnage tool work for me?

  • Rich

    I have a unjailbroken 3G[S], Can I jailbreak it with the new pwnage? I’m running firmware 3.0.1….

  • Pat

    Hi,
    can’t figure it out.

    I am using a 3Gs with OS 3.1 updatet via iTunes but factory unlocket. I have submitted my SHID to Cydia once I was on pwnaged on 3.0. So Is there a way to jailbreak my phone and I mean JUST (without nlock) jailbreak 3.1?

  • Robert Lozano

    I just witnessed yesterday a 3G upgraded to 3.1 through itunes 9 (latest version)
    jailbroken. It can be done. its the 3GS the one that can’t right now.