Another quick update on the state of the iOS 5 untethered jailbreak: French hacker pod2g has confirmed that the iOS 5 untether will in fact work on iOS 5.0.1.

It was originally thought that 5.0.1 had patched the untethered jailbreak, and we recommended that jailbreakers stay on 5.0 if they wanted an untether in the near future. We’re pleased to report that potential jailbreakers on iOS 5.0.1 can breathe a sigh of relief.

Pod2g’s untether (we have a video demo) doesn’t rely on the code signing vulnerability that security guru Charlie Miller recently demonstrated. Miller’s vulnerability was one of the reasons that Apple released 5.0.1 (to patch the vulnerability), and it was believed that 5.0.1 wouldn’t see an untethered jailbreak because of that reason.

Pod2g says that bringing his jailbreak to 5.0.1 “should be quick.” He is currently testing the jailbreak on different kinds of iOS devices.