Cydia Substrate isn’t the only tweak injector receiving new updates as of late. Libhooker, the premier tweak injection method for the iOS 13-based Odyssey jailbreak and for the Odysseyra1n script for the checkra1n jailbreak, just got a fresh upgrade to version 1.3.0 with some notable improvements.

Odyssey Team lead developer CoolStar announced the updated libhooker release Saturday night via Twitter, and further described the update and everything it brings in the official Discord channel:

From what we can gather, libhooker v1.3.0 brings the following changes:

– Optimize Objective-C hooks so that less memory is used (benefits all tweaks)
– Optimize C hooks for tweaks that are updated to use the libhooker API directly so that less memory is used (e.g. Anemone 3)
– Fix hooks failing in some cases on iPhone 5S and 6 w/ iOS 12 [this fixes newer Anemone 3 and RocketBootstrap on these devices with Odysseyra1n/Procursus-Chimera]

As you probably already noticed, this update brings a lot of optimizations and bug fixes that should make hooking a lot more reliable and stable. Not only is it lighter on system resources after this update, but it resolves problems with devices that aren’t equipped with as much memory as some of Apple’s newer handsets are.

If you’re using the Odyssey jailbreak or Odysseyra1n script on your checkra1n jailbreak, then the latest libhooker update should be available via the default Odyssey repository via your favorite package manager and is recommended for all users of these jailbreaks. Obviously, this doesn’t apply to standard checkra1n users or unc0ver users as these jailbreaks use Cydia Substrate and/or Substitute for tweak injection instead.

One thing worth noting is that if you were testing the libhooker v1.3.0 beta before tonight’s official update, then the official update may not appear for you. If this is the case, then CoolStar recommends uninstalling the beta repository and using the 3D Touch/Haptic Touch gesture on the Modify button in Sileo to ensure that you install the latest version. This should set things right and allow you to install the official libhooker v1.3.0 public release.

Have you upgraded libhooker on your Odyssey or Odysseyra1n device yet? Share in the comments section below.