TinyUmbrella updated with support for iOS 6.1.2

By , Feb 27, 2013

shsh tinyumbrella

In light of Apple releasing iOS 6.1.2 last week, notcom has seeded a new version of his TinyUmbrella app. The popular SHSH blob-saving tool now supports all versions of iOS, excluding 6.1.3, which is still in beta.

That beta, though, is already causing waves in the jailbreak community. Evidence has been found in the firmware that Apple is patching evasi0n‘s exploits, which makes this TinyUmbrella extremely important…

From the official TinyUmbrella blog:

“TinyUmbrella has been updated to work with iOS 6.1.2 on relevant devices. Make sure you don’t update to 6.1.3 when it drops. I wasn’t able to get 6.1.3 beta included (I just got too busy). But if you desire to keep your jailbreak, avoid 6.1.3 like the plague.”

The caution stems from a report from earlier this week, in which evad3rs team member planetbeing told Forbes that Apple has patched at least one of the five exploits that evasi0n uses, essentially killing the jailbreak.

So for all of you who updated to iOS 6.1.2 last week to resolve the Exchange bug, you’ll want to make sure that you use this new version of TinyUmbrella to backup your blobs. If you need help, we have a great tutorial.

If you don’t need help, you can grab the latest version of TinyUmbrella (and other jailbreak software) on our Downloads page. Just make sure you use it on all devices, and like notcom says, avoid iOS 6.1.3 when it drops.

  • Share:
  • Follow:
  • seyss

    did you know when you launch Cydia it saves your blobs in a remote server? so you don’t have to worry about saving it manually, store/managing blob files ,etc

    • http://www.facebook.com/profile.php?id=829245704 Matthew Cleveland

      True, but backups never hurt. :)

    • smtp25

      Question: You can only run Cydia if jailbroken. So what happens if you are on non-jailbroken phone due to accidental upgrade, how do you access Cydia to get blobs back?

      • seyss

        TU also grab blobs from Cydia servers.. so does redsn0w and other hacking tools

    • http://www.idownloadblog.com Sebastien

      Yes we know. But we also know that you’re better safe than sorry :)

    • EpicFacepalm

      Still you need Tinyumbrella for non-jailbroken devices for future jailbreaks.

  • Guest

    can anyone tell me that, it will be possible to upgrade from 5.1.1 to 6.1.2 after the relase of 6.1.3?
    I want to stay in 5.1.1 till i can :)
    i have 6.1.2 shsh blob for my 4s

    • http://twitter.com/patchcable patchcable

      with a shift+restore in itunes and TU in TSS server mode its possible

      • smtp25

        on an iPhone 4 maaaaybe. but pretty sure not if they not signing that ios version anymore

      • leart za jmi

        So if you own a A5+, theres no posibility to use shsh blobs for nothing, just hoping if came out a method for downgrading…

    • Wassim Omais

      If its 4S I don’t believe that you can. TSS Server and Option Click restore only works on A4 and below. (Geohot’s limera1n exploit.) There is no such low level Boot ROM exploit for A5 + devices so if you want to update a 4S you should do it now.

      • leart za jmi

        Thanks man.
        i bought my new 4s in late november.
        surprisely i found that it was manufactured in august, so it came with 5.1.1
        jb in this ios works great and i was hoping to use it for some time more….

        Looks that is not possible to upgrate to the non leatest ios, wondering why to take care of shsh blobs anymore, they are useless now.
        Anyway thnx for the answer, helped me alot :)

    • http://twitter.com/oneBurge Burge

      On a 4s no .. When apple stop signing 6.1.2 and only sign 6.1.3. If you try to get to 6.1.2 it will fail.. Update now..

      • http://twitter.com/patchcable patchcable

        Ahh 4S good spot, yea you would have to wait for a new JB or an expoilt in the new security features for +iOS 5.1.1 FW’s

        But you know what they say “necessity is the mother of all invention”

  • Guest

    can anyone tell me that, it will be possible to upgrade from 5.1.1 to 6.1.2 after the relase of 6.1.3?
     I wany to stay in 5.1.1 as long as possible :)
    i have 6.1.2 shsh blob for my 4s

    • smtp25

      no you can’t, because they stop signing 6.1.2 when 6.1.3+ comes out.. I’ve heard there are a few days after release where they still signing but wouldn’t risk being stranded on wrong iOS (either old or non-JB-able)

  • http://twitter.com/bongojenga Marcel Herba

    Why they still not added in-app updates?

  • M Last

    finally moved their ass and updated it.

  • http://twitter.com/timgee94 tim g

    why does tu still need updates for new firmware! its getting ridiculous. I am, however greatful of the many hours @notcom has poured into it

    • http://twitter.com/oneBurge Burge

      It gets updated when a new firmware is out because it has to recognise the new firmware

  • Marshall

    thx for sharing ^.^v

  • http://twitter.com/Alfu_ Alfu™

    Tiny Umbrella fails
    to run on my laptop. Anybody have any clue why that is happening. By the way my
    laptop is windows 7. It prompts me to download java which I already have on my
    laptop but for some reason it fails to run.
    help needed pls if you know what am
    talking about.
    thanks

    • Ray V

      I don’t know if this your problem but make sure you run as administrator

    • http://twitter.com/patchcable patchcable

      Check the log file but you have probably blocked java in your firewall. Take it off auto and delete any old rules for either java or TU. if you still get issues do some testing using windows’s limited (but with networking) startup.

  • http://twitter.com/dpbiscuit D1M

    This is going to sound so retarded, so apologies. But what does TU actually do?

    Example. If I have a jailbroken iPhone 5 on 6.1.2 and something happens to it, then say I get a new iPhone but 6.1.3 has already come out and theres no JB for it.

    Can I then DOWNGRADE from 6.1.3 on the NEW device to 6.1.2 and then JB? Is that what it is?

    • http://twitter.com/vipulkv Vipul Verma

      yup, you need SHSH blob to downgrade iOS.

      • http://twitter.com/dpbiscuit D1M

        Thanks for the reply Vipul :)

      • http://twitter.com/tayyabsa Tayyab Sadiq

        But there isn’t any way to downgrade

    • http://twitter.com/oneBurge Burge

      No… The shsh only works with the device it came from..

    • Milad Khahil

      You can’t downgrade iphone 5 even if you have your SHSH blobs saved at this time , it only works with older devices …

    • EpicFacepalm

      It’s good to have because there is a possibility that jb hackers may find a loophole exploit and release a tool that downgrades A5+ devices in the future just like they did on iOS 5.x.

    • http://www.facebook.com/bohemianvirgo J Willis Burch

      Can the iPad 2 be downgraded?

  • http://twitter.com/painterface painterface

    I have an iphone 4 on 6.1.1…do I need to do anything?

    • http://twitter.com/vipulkv Vipul Verma

      just save shsh blob for future…

  • http://twitter.com/paolokhayat paolo khayat

    saving iphone 4S SHSH 6.1/.1 still doesn’t work!! help please

  • http://www.facebook.com/people/Jack-Desmond/100001060330310 Jack Desmond

    Yes, Cydia saves SHSH. I wouldn’t rely on it, though, so I use iSHSHit (app from Cydia) as well as TinyUmbrella to save them in multiple places. Then I copy them to Dropbox to boot. Paranoic? Maybe. Especially since I switched to the iPhone 3GS in late-2009 and my first JB was on 3.1.2, I’ve never needed to downgrade.

  • http://www.facebook.com/barz91 Alpay Barz Ozalper

    Somebody please explain to me how you use the saved SHSH blobs to get back to 6.1.2 if i accidentally updated or ha to restore due to a problem on cydia and i ended up on ios 6.1.3 because i have no clue on doing this. if anyone has the answer please let me know. reply here if i will be notified if not please email me aozalper@gmail.com

  • 987654321z

    already saved them in iSHSHit then on a USB

  • http://www.facebook.com/justin.sully05 Justin Sully

    i accidentally went to 6.1.3.. i have an iphone 4 and when i try to downgrade back to 6.1.2 itunes is giving me an error… anyone help with this? thanks