Having trouble with iBooks on the latest Corona untether for iOS 5.0.1? Never fear, pod2g has said that an update is coming to resolve issues with iBooks crashing on iOS devices running the Chronic Dev Team’s latest jailbreak.

We’ve already told you how to fix issues with iBooks on iOS 5.0.1, but those of you that are still having trouble after using Corona can look forward to pod2g’s upcoming update.

@xvolks worked to include @comex sandbox patches into the Corona GIT.

Expect a Corona update soon in Cydia that’ll fix iBooks and other softwares having sandbox issues.

If you haven’t already jailbroken iOS 5.0.1 with the Corona untether, you can learn how to do so here. We’ll let you know when an update is released to officially fix the issues with iBooks.

  • I used Redsn0w and my iBooks does not work on iOS 5.0.1. What do we do?

    • Anonymous

      Whenever an iBooks fix needs to be applied……….You must delete iBooks and download it from the App Store “ONLY” …………….And not open the app AT ALL until the fix is applied…………………iBooks fix does work…………..As long as you DL from the App Store and don’t open the app until until the fix is applied…………….

  • Tanju Hasan

    For a second I though the A5 Jaibreak is out… The wait is killing me xD

    • Anonymous

      Every time there is an iOS 5 untether bug fix announcement, there is always at least one person that says……..”Aaah i thought for a second this was the A5 release”. Tho i feel your pain……………I mean I don’t have a 4S but i know, I know……………waiting sucks.lol

  • Don

    this just means it really cant be that long anymore…
    if hes now working on corona related issues and
    the dream-team has already solved the mistery of the sandbox
    we might just see that jailbreak sooner that next week
    (no pressure dudes)

  • Anonymous

    Hopefully this isn’t the same “train wrecking, daemon killing, restore causing” POS that Corona 1.0-3 is!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!HINT HINT

  • Should work wonderfully. This will be a kernel level fix. That’s the way it should be.

  • Will this be fixed in a new version of Redsn0w, too?

  • redsn0w 09.10b3 did not require Corona at all for an untethered JB on iOS 5.0.1, right? So will this also apply to users that used redsn0w 09.10b3?

  • Just make it a system application. That fixes it too.