The Dev Team has released beta 3 of RedSn0w for the Mac and PC to fix an error that caused MobileSubstrate to sometimes crash on jailbroken iOS devices. This specific error only seemed to crash MobileSubstrate when the latest iOS 5.0.1 untether in RedSn0w was run over an existing jailbreak.

From the Dev Team blog:

The b3 version of redsn0w fixes a problem where re-running redsn0w over an existing jailbreak would cause MobileSubstrate-based apps to stop running until MS was installed again.  Now you can re-run the redsn0w jailbreak step without worrying about that (but still remember to de-select the “Install Cydia” option if it’s already installed).

Another tip: If RedSn0w tells you that no identifying data was found when it auto-detects your IPSW, then you can pre-select your iOS device’s 5.0.1 IPSW in RedSnow’s Extras >Select IPSW menu.

As always, you can download the latest RedSn0w beta from our Downloads page. This latest beta follows an update from yesterday that fixed the “launchctl” error in Cydia. We have a dedicated RedSn0w page with everything you need to know about the jailbreak tool, and we have tutorials for jailbreaking iOS 5.0.1 for both the Mac and Windows.

  • L F

    noticed this issue glad to see that pod2g is still working on this jailbreak. It was pretty buggy when i first jailbroke on 5.0.1 but it seems to be working fairly smooth now. now if only we could fix the multitude of bugs everyone has noticed in ios 5 (ie: slower performance, glitchy coverflow etc.)

    • Anonymous

      Uh, pod2g is currently concentrating on the A5 devices’ jailbreak?

  • Yesterday I ran beta 2 over a clean restore of 5.1.

    Is there any benifit to run beta 3?

    Thanks
    James

    • Artunc Özaydın

      ı did same but no ıssues expect ibooks(still error and cant open) they say thıs for rejaılbreak not fotr clean restore or ı get ıt thıs way no need to use b3 for restore

    • Yes u need to run it or u may have mobile substrate problems

  • Hopefully this will solve some of the issues I have been having this morning on my i4

  • Anonymous

    OK, fine, good job now please fix iBooks.

  • YouTube + Corona = Safe Mode

  • Anyone experiencing Signal Issues? on Redsnow b2? notice this after rejailbreak my iphone from b1 to b2 redsnow, sometimes my signal drop and indicate searching i need to restart my iphone to be able to have a signal again.

    • YES! I’ve got The exact same problem! Not sure how to report, nor to whom I should report the bug to??

      • Anonymous

        Same here!!
        Restarting does not work for me.
        When I switch off 3G my signal is fully restored.
        When switching on 3G signal drops again.

        I have tested with ‘signal’.
        Whith 3G on my iphone can’t link to the different masts.
        With 3G off it can.

  • Dan

    I’m fine so far, so guess I won’t be using this

    • Anonymous

      My Chase Mobile, Facebook and iBooks apps are not working. Chase and Facebook apps hang at launch screen.

      • Dan

        weird, I jailbroke my gf’s ipod 4 with this and facebook is working perfectly. I did a complete restore to 5.0.1 then jailbroke with redsnow.

      • Tiago Fernandes

        But; when you complete restore, don’t you lose all your apps and data?

      • same thing happened to me, i remove spire and chase and facebook started working. i dont use ibooks.

  • Anonymous

    I did a clean restore and used the latest Redsnow (prior to this version of course) and sometimes sbsettings froze and then re-sprung my phone into safe mode, I don’t know if this recent bug fix was the cause but it was only 1 of many problems I experienced with the 5.0.1 untether, whether it be the jailbreak itself or tweaks that caused memory drain and random resprings and reboots.

  • it not really fix all things… Tomtom still not loading and Infinite sms still bugg sometime it just white or crashed and froze iphone for 5-10sec.

    • Same here !

      • I got a fix for your Tom Tom, pretty much the problem is spire. Uninstall that and Tom Tom will work again after a reboot, just tried it and TomTom is good now.. Goodluck

  • Anonymous

    We can add Navigon to that list as well. Also Cydia will not refresh… Does anyone have any advice?

    • Kok Hean

      Refresh again.

      • Anonymous

        LMAO REFRESH AGAIN

  • Carmen Yeung

    I have JB with redsn0w b2 and Cydia will crash everytime I try to add a source or do a search (even after I wait for everything to finish reloading).

    I have then restored to factory settings and reJB again, but the same problem persists. Does anybody have a solution to this?

  • Thanks!

  • Does anyone here been able to have a different bootlogo that works? Because everyone i try to use does not work and it just stays as the normal apple bootlogo.

  • After installing LockCalender on my 3GS 5.0.1 the phone goes in safe mode and all of my cydia app dont work, any one that have the same problem, any fix ?

  • I ran Redsn0w Beta 1, then installed the Corona update for the launchctl error. Do I still need to run Beta 3 or will there be a Corona update for this problem?

  • Some of the problems people are having with the tweaks are simply because some aren’t compatible yet. There was a list floating around with tweaks that are compatible with ios5. Check the list before adding things. As for Cydia, it’s overloaded right now. Best time is late at night. I did my phone last night and it went smooth. Just my 2 cents. Hope it helps.

  • I used to desperately have to search for fixes like this, then I grew up and quit jailbreaking my iDevices. HaHa I win! =)

  • Anonymous

    I updated my 3GS 6.15 to 5.0.1 and now it is not accepting any SIM card!!!! I have AT&T so it should not have been a problem. And I tried to get it back to 5.0 with the custom firmware I made with iFaith but it’s failing. HELP!!!!!

    • make sure that you turn OFF your 3g after you install Ultrasnow

      • Anonymous

        I have AT&T, so I don’t need Ultrasnow. I tried both: custom firmware and the original one from Apple. No Luck!

  • kpsmlng 701

    I downloaded something in cydia called ibooksfix2 (I think) and working perfectly fine now.

  • i am facing a problem once i jailbreak the Iphone IOS 5.0.1, and then the phone works fine, however, once i install switcher plus from cydia the phone crashes and i it will not reboot it will stack on apple logo.

    seeking your help here.

  • ace ash

    For me the problem os that the dev team source doesn’t work at all even when I restore and jailbreak it over and over and still it doesn’t even work

  • ios5 is really buggy still….Skype gets stuck on the login screen everytime i open it, only when i delete the app n reinstall it, it opens once to ask for login details, i can enter the app, but as soon as i click home button and skype is in backgroud, thats it, gets stuck on the login blue sceen when i open, hard reset to no avail, i cant be always deleting and reinstalling the app everytime i need to make a skype call….not to mention cant receive calls on backgroud….
    UPDATE: skype issue also solved by uninstalling spire

    another bug i found was entering a phone number and saving to existing contact, didnt happen, had to manually copy paste to contact..

    one issue which was solved was that tomtom wasnt working, but the solution was to uninstall spire

  • redsnow crashes upon trying to boot / re-jailbreak / fix restore error etc. anyone else having problems getting this application to do anything for them? im on windows 7