The Sn0wBreeze jailbreak tool has been updated to version 2.8b6 with support for iOS 5 Beta 6. This jailbreak is Windows only.

If you don’t know how to use Sn0wbreeze, check out our tutorial. This jailbreak is mostly tethered, except for the old-bootrom iPhone 3GS. This version of Sn0wBreeze will also let you install the jailbreak on a copy of iOS 5 Beta 6 without a registered UDID.

As noted in the last version of Sn0wbreeze, you have the ability to install iOS 5 without a developer account. Along with that, the expiration date for iOS 5 Beta 6 has been removed. For users that need to keep their unlock, this version also preserves the baseband.

Here is the change log for this version of Sn0wbreeze:

  • Now jailbreaks iOS 5 Beta 6.
  • Still removes UDID Developer check + Beta timer.
  • Still has the ability to hacktivate.
  • Still preserves the baseband (as always!).

Supported Devices and Tethered?

  • iPhone 3GS (old bootrom)…….NO (Yes to untethered)
  • iPhone 3GS (new bootrom)…..YES
  • iPhone 4 (GSM)…………………YES
  • iPhone 4 (CDMA)………………YES
  • iPod Touch 3G…………………..YES
  • iPod Touch 4…………………….YES
  • iPad 1G……………………………YES

iOS 5 Beta 6 has some new changes, and it’s definitely more snappier. iOS 5 is currently a beta, so installing it on a device you use daily wouldn’t be a good idea.

You can download Sn0wBreeze 2.8b6 from our downloads section. You’ll have to find a copy of iOS 5 Beta 6 on your own.

Let us know how it went jailbreaking iOS 5 Beta 6 with Sn0wBreeze. Run into any problems?

  • kokhean

    I restored an iPhone 4 to iOS 5 Beta 6 (custom firmware), and since I don’t have a micro-SIM, I chose hacktivation. The phone apps, the messages app and all the other icons disappeared, so I restored back to 4.3.5.

  • I asked this on an earlier post, but no one really answered me. If I only disable the UDID check and beta timer, will it still be tethered (no Cydia/moving around filesystem/jailbreak)?

    • dylan

      It’ll still be jailbroken

    • Burge

      It will still be tethered …

    • QuarterSwede

      You won’t be able to open Safari without it being tethered. It’ll boot and run fine otherwise.

      • Thanks man. I’ll wait for the official release then.

  • Prash

    Hey guys.. Will ultraslow unlock work with this iOS 5 B6 ?? I’m currently in iOS 4.3.3, unlock is very important me.. Can someone who tried this already help me?? Please reply

    • at least u can tell which device u r using,,, dont post such a dumb comment buddy! Well its only Unlock the iPad Baseband device as now iPhone 3GS!

  • James

    ill add anyone to my dev portal for free just reply to my comment here

    • Alex

      Hey. Can you add my Udid plz. How i can sent my UDID? My Mail:oriony_rad@yahoo.com

      • James

        Sent you an email man

    • ibm

      Hey. Can you add my Udid plz. How i can send my UDID? My Mail:chronical786@hotmail.com

  • Daniel

    I have just downloaded this tool and it sais that my IPSW isn’t valid…

  • MALdito

    Now all I have to do is find a copy of iOS 5 Beta 6 and I’m all set! <—(Easier said than done)

    • dylan

      Imzdl.com

    • QuarterSwede

      Or BitTorrent. Knowing reputable sites hosting torrents is half the battle. Good keywords is the other.

  • Soto

    I found iOS 5 beta 5 on the piratebay website, they probably have beta 6. Any one with the download link?

  • Hey iDownloadblog.com Ur information is missing something or u can say that its like bugged!
    Supported Devices and Tethered?

    iPhone 3GS (old bootrom)…….NO
    iPhone 3GS (new bootrom)…..YES
    iPhone 4 (GSM)…………………YES
    iPhone 4 (CDMA)………………YES
    iPod Touch 3G…………………..YES
    iPod Touch 4…………………….YES
    iPad 1G……………………………YES

    But iPhone 3GS (Old bootrom) is Supported and also Untethered (only 3GS+Old bootrom)… Correct ur information guyz. Its correct on other site but not on yours, also tested by me! Else i like ur website!

    • Its not missing. All supported devices are listed. The iPhone 3GS with the oldbootrom is not tethered so thats why it says no.

  • Karol

    is itunes and iMessages working with out UDID ? and telephone normaly ? i remember that in beta 1 it doesn’t works

    • QuarterSwede

      If it works by way of modifying the SystemVersion.plist then, yes, everything works except for OTA updates. I’m not sure what it does though.

  • Ash

    How can I download ISO 5 Bate 6, and from where, which web.
    I an non developer

    • dylan

      imzdl.com , thepiratebay.org, etc

  • Nino

    Can i unlock my iphone 3gs bb 6.15.00 on ios 5 beta 6?

  • Chad

    I keep getting a 3194 error when trying to load the custom firmware on an iPad 1. I have tried every suggestion (tiny umbrella, hosts file changes) and still receive it. Any suggestions? Thanks!

    • Ash

      Form where you download 5bate 6

      • Chad

        Hi Ash,

        Thanks so much for the reply. I’m DLing from imzdl I had no issues with the firmware for my iTouch 4. Using it now.

        Thanks again!

  • Ash

    Chad from where you download ISO 5 bate 6, please could you tell me.٠

  • Alex

    hey Chad. If you have error 3194. You must be open C:/windows/system32/drivers/etc/host. HOst file you must open a notepad and remove all sentens with “apple”. After that you must be restar your PC and all will be ok . SOrry foe my bad English

  • Prash

    I use iPhone 3GS with iOS 4.3.3(ipad Baseband 06.15.00). I badly wanna use iOS5 Beta 6. The main issue here is, i completely depend upon unlock. Is it possible to unlock this iOS 5 Beta 6 via ultrasn0w or something ?? Please let me know.

  • rian

    if i install iOS 5 B6 on my iPhone 4, will i be able to restore back to the latest version of iOS 4? i don’t wanna do this and be stuck as a developer phone! pls comment back 🙂 and let me kno !

  • juggy

    ok, dumb question of the year. if I jailbreak the phone and install ios 5 beta 6. will the phone still be unlocked? I still want to be able to update OTA ios with a locked phone.

  • reza

    I have just downloaded this tool and it sais that my IPSW isn’t valid…

    • Rian

      Yea I have gotten that same error towards the end of the progress bar:/ idk what I’m doing wrong or if it’s jus the software

  • KaneCabal

    Hey guys, for some reason even when you are changing the host file, apply tinyumbrella some devices still get an error 3194 code. As Chad said, his iPod Touch 4th iOS 5 Beta 6 works, but not on the iPad. So what is the fix for it? Host file changes doesnt work, iREB doesnt work, nothing works.

  • tmgage1

    Can i unlock my iphone 4 in ios 5 beta 6? it is so frustrating i have t-mobile

  • Is there anything for ipad 2? I’m on Version 4.3.5 which i understand will not have a JB released, but was hoping one of the IOS 5 betas would be.

  • Robert

    Hey Guys, been reading and I do have iPhone 3GS Model MB. This would be perfect for me as I’ve already bought T-Mobile sim. I’ve never Jailbroken any iPhone. With this said, will this file do it for me? Reason this is important to me is AT&T is ripping my head off at 115.00 per month.

  • Mamun

    I can confirm iPhone 3G(S) with OLD BOOT ROM is unthethred jailbroken by sn0wbreeze…Hurray! with unlimited career lock 😀

  • FaZe vFuture

    Okay I have an iPhone 3GS and i have T-Mobile and it is running on 4.3.5 firmware with 06.15.00 baseband… Every time i try to upgrade I get the (3194) error even with using tiny umbrella do I have to download a custom firmware to upgrade… need someone’s help fast!! I’m getting Apple to sign with T-Mobile so t-mobile can sell iPhones and they need proof I can use tmobile with iso5. Please email me at Jphockey6@yahoo.com if you can help me upgrade, then to all the tmobile users out there u won’t have to unlock if u guys can help!!