Saving your SHSH blobs is the single most important thing you can do to preserve your jailbreak. If you ever accidentally upgraded to a new version of iOS that hasn’t been jailbroken yet, saved SHSH blobs would help you downgrade.

The new version of TinyUmbrella is out (version 5.00.77), and not only does it allow you to save your SHSH blobs for the new 4.3.5 firmware, it also gives you the choice of whether or not to update your iPhone 4’s baseband…

The new feature will enable users to pick whether or not they want to update the iPhone 4’s baseband, allowing you to mix and match a new baseband with an older version of iOS. But the new option doesn’t come without a few warnings:

1. The version you WANT to restore to and the version Apple is currently signing must BOTH have the same baseband. This is important or else the baseband update will not work.

2. You need to realize that checking the box WILL UPDATE YOUR BASEBAND.

Notcom also comments that TinyUmbrella doesn’t save your Update iPhone 4 Baseband setting, so you need to make sure you are checking it every time you run TinyUmbrella. Obviously, if your iPhone is unlocked on an earlier baseband, you want to stay away from this feature.

If you are still confused as to why you need to save your SHSH blobs to downgrade, click here for our ultimate downgrade guide. Otherwise, you can grab the latest version of TinyUmbrella by clicking here.

Any questions?

  • why does the download link point to a .package version of the program?? what the heck is that?

  • Yuval Marcus

    I don’t get it yet please someone help! Let’s say I want to downgrade 4.3.5 to 4.3.3, but I don’t rely on an unlock at all. I have an AT&T iPhone 4. so i don’t need an unlock. What DO I DO!!!

    • As instructed in the article, simply follow our downgrade guide.

      iDownloadblog.com/downgrade/

      • Yuval Marcus

        I don’t understand. I just want to downgrade like before on Older versions of TU

      • Yuval

        So should I click the box or not?

  • ic0edx

    I’m stuck on iOS 5 Beta 3 and can’t go back to 4.3.3. I do have my 4.3.3 Blobs saved but for some reason I can’t downgrade. I tried uninstalling iTunes but you can’t on OS Lion. I WANNA GO BACK 🙁 Also when I put my iPhone in DFU mod it does not show up in TU for me to select 4.3.3 blobs so I can start the TSS server. HELP!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    • i went down from ios5beta4 to 4.3.3 using tinyumbrella and and fixrecovery. u need to use a pc

    • also u need the latest(non beta version of itunes) NOT the beta one. dont worry about TU not seeing your iphone in dfu mode, thats normal

  • Lupius

    Is there gonna be detailed instruction on how to actually preserve baseband using Tiny Umbrella? Is it a matter of simply updating in iTunes with TSS server running and the new option unchecked?

  • Anonymous

    i have an iphone 4 running ios 4.3.5 baseband 4.10.01 it is unlockable baseband by gevey. but it is stuck in dfu mode and always i am getting errors 3194 and 1013. if i check the box UPDATE IPHONE 4 BASEBAND on tiny umbrella to get rid of error 1013, Do i lose my current baseband?
    so i try it on itunes 10.4.1, it updates 4.3.5 and it should update the baseband 4.10.01 as the last, i mean it shouldnt change the baseband if check the box UPDATE IPHONE 4 BASEBAND but i am not sure.
    anybody has an idea about this matter?

  • Faseeh Munir

    i updated my i phone 4 frm 4.3 to ios 6.0 n i was using it with gevey sim n nw its lock i can onli see a grey back ground n a white iphone written on it , im new to iphone n totally lost plx help