Apple recently released iOS 4.3.5 to patch a few security vulnerabilities, and RedSn0w has already been confirmed to offer a tethered jailbreak on Apple’s latest firmware.

If you’re on an iPhone 4 with an unlocked baseband, jailbreaking iOS 4.3.5 with RedSn0w will not preserve your baseband. Luckily, a custom build of PwnageTool has been released to fix that problem.

The folks at Redmond Pie have put together a custom PwnageTool bundle for the iPhone 4 that will jailbreak iOS 4.3.5 and preserve an already-unlocked baseband. Newer basebands do not receive an unlock.

You’ll need iOS 4.3.5, iTunes 10.4, a tetheredboot utility, and PwnageTool 4.33, which you can find in our downloads section. (PwnageTool is Mac-only software.) To learn how to jailbreak with PwnageTool, refer to our tutorial.

To get the custom build of PwnageTool that you’ll need to keep your iPhone 4’s unlock, head over to Redmond Pie and download their custom build package. They have a guide on how to modify PwnageTool with the custom build, too.

It’s recommend that all jailbreakers stay on iOS 4.3.3 for the most up-to-date untethered jailbreak. You can jailbreak all iDevices on 4.3.3 with JailbreakMe.

Let us know if you decide to use PwnageTool on iOS 4.3.5. Or are you staying on 4.3.3 to keep your unlock?

  • ic0edx

    Why would anyone want to update to 4.3.5 is it does not offer any new features. People please just stay on 4.3.3 and that’s it.

    • Evoss

      very wise comment

  • Ken

    It means snowbreeze soon update for 4.3.5 too

  • Andres

    Hi!
    Does anyone know how to upgrade from 4.1.2 to 4.3.3 to jailbreak with jailbreakme?
    I´m already downloading the firmware from the downloads section but don´t know what to do next.

    • Ken

      You can’t use jailbreakme since apple push out 4.3.5 in itune.
      I can suggest you to try sn0wbreeze on 4.3.3 to jailbreak on windows.
      For mac using pownagetool is the best I think.

  • Rafael

    Let’s say I’m in 4.2 and want to upgrade to 4.3.3 preserving my 01.59.00 bb today. I can make a custom firmware with pwnagetool on a Mac but if I try to use this ipsw to restore with iTunes it will probably say that I can’t do it since 4.3.5 is out, right?

    What should I do? Use tinyumbrela?

    • M

      i dunno about baseband (my phone’s factory unlocked), but you won’t be able to “upgrade” to 4.3.3 unless you have your shsh blobs already saved. that’s the first and most important thing to bear in mind. if you don’t then there’s absolutely no way around it so don’t waste your time searching. your only options would be to stick with 4.2 (you can extract the blob for that directly from your phone using ifaith) or upgrade to 4.3.5 or the ios 5 betas.

      • Rafael Zanatta

        Yes that´s correct. I have my SHSHs saved since 4.0.2 in tinyumbrella and SHSHit.

    • M

      tinyumbrella and pwnagetool should be able to do it then – i think from what i can see anyway. just make sure you have your tinyumbrella options setup properly and click “start tss server” before you fire up itunes for your restore.

  • Acolz

    Allright, anyone help me please?
    I have iPhone 3GS – 4.0.1 ultrasn0w unlocked and hacktivated on 05.13.04.
    How to update to atleast 4.2.1 while preserving baseband for unlock on Windows 7 x64?

  • MusikerongBundukero

    Made a mistake! I have iOS 4.3.5 now, with BB 1.59.0 without realizing I need a Gevey SIM to unlock. Is there a way to go back to any iOS preserving the 1.59.0? It was iOS 4.0.1.. someone, please help. I’m stuck up.. this iPhone Touch is useless for me.

  • Erik

    Question: Is it still interesting to keep older baseband (02.10.04 and higher) as no unlock seems to be worked on. And now, with the arrival of iOS 5, will there still be development in that area?

    • forget a new ultrasn0w. there are too many other options available, not to mention factory unlocked iphones are now being sold in the USA. dev team has more important things, such as future jailbreaks, and not to mention the obvious…they cant unlock it anymore.

  • Afghan

    How to jailbreak 4.3.5 in win

  • SOHIL

    Anyone successfully downgraded 4.3.5 to 4.3.3?

    If yes than please help me out how?

    Please
    Thanks in advance

  • rain

    Not successful but I was able to make my phone work with 4.3.5, updated BB, unJB, with the use of microsim.

  • rain

    With the use of a Gevey SIM interposer I mean.

  • Bes

    i have a white iphone 3GS on 4.3.5 with baseband 5.16.02. Is it possible for a jailbreak and unlock? Please let me know what can be done!

  • Bernie

    THANK YOU FOR YOUR HELP – I have an iPhone 4 with 01.59.00 firmware and running iOS 4.3.3 (8J2). I’ve been preserving my BB for the moment to unlock to come; and today is about time. Anyways, I’ve had 4.3.3 since a couple of days after it was released and now I need to do a clean RESTORE: my iPhone is pretty darn slow and full of junk I don’t use anymore. I want to know if RESTORING to 4.3.3 again is possible without updating my BASEBAND or screwing up in any way. I really, I mean -REALLY- can’t afford loosing my 01.59.00 unlock BB. I’ve seen how to do it with TinyUmbrella but I’m afraid something could go wrong. Any thoughts? Again, thanks a lot.

  • hamid

    heyy i have iphone 4 4.3.5 and i jailbreaked it but my safari and cydia ..not working.. any one can help me? and who know when can i have untethered jailbreak for 4.3.5????? plzzz

    • Saavedra

      Go to redsn0w 9.8.b7 and Ipws 4.3.5
      And you have every Thing .

    • Saavedra

      Go to redsn0w 9.8.b7

    • Saavedra

      Go to redsn0w 9.8.b7.

  • chelo

    how to downgrade iphone 4 , 4.3.5 to 4.3.3 without the shshs? pleaseee!

  • Mikey

    Hi I have iPhone 4 with 4.3.5 unlocked using tmobile, I was advised not to jailbreak the phone due to tethered jailbreak (whatever that means), what should I do? I really want to jailbreak it but will I have problems with my iPhone everytime I turn it on would anyone suggest to jailbreak it??