A couple days after making TinyUmbrella compatible with iOS 5 Beta 3, and following the release of iOS 4.3.4, Notcom has updated his tool yet again, this time to allow you to save your iOS 4.3.4 SHSH blobs.

Because you’d better be safe than sorry, we highly suggest you download the latest version and save those blobs. In case you don’t know what we’re talking about here, feel free to peruse our SHSH guide, as well as our tutorial on how to save your SHSH blobs

Head over to our download section to download the latest version of TinyUmbrella.

  • Don’t drink that racist coffee.

    Why on earth would you want to downgrade to 4.3.4? iOS 5 will be out soon anyway!

  • Jacksparrow

    Exactly as that dude posted this makes no sense to me.

  • kokhean

    To the 2 ignorant posters above, Apple made iOS 5 harder to exploit, meaning that the untether for iOS 5 cannot be easily coded.

  • Braulio

    Well instead of downgrading to 4.3.4 which is a ‘tethered’ jailbreak. People should downgrade to 4.3.3 which is ‘untenthered’. I do not recomend people upgrading to iOS5 until the dev team comes out with an untethered jailbreak because people are going to be annoyed with a tethered jailbreak. If a person doesn’t care about the tethered jailbreak then go ahead and do it.