Thanks to the hard work of the iPhone Dev Team, the UltraSn0w unlock for iPhone has been updated to play well with iOS 4.3.3. As mentioned in our previous post about UltraSn0w, this will only work with iPhone 4 baseband 1.59.00, and iPhone 3G/3GS basebands 4.26.08, 5.11.07, 5.12.01, 5.13.04, and 6.15.00.

If your baseband is different from these, then you can’t unlock for the time being. If your baseband matches one of those above but you are on an older firmware, use PwnageTool to update while preserving the baseband.

In this tutorial, we will show you how to unlock your iPhone 4.3.3 using UltraSn0w…

Step 1: Make sure your baseband matches any of the basebands listed above. If it doesn’t, you can’t unlock. If it does, you may update your iPhone to 4.3.3 while preserving the baseband using PwnageTool. Note that you don’t have to update to 4.3.3. If for example you are still on iOS 4.1, you may stay there and still use UltraSn0w.

Step 2: Make sure your iPhone is jailbroken. The easiest way is to use RedSn0w, although it can be tricky as you might accidentally update your baseband. Which is why I suggest you use PwnageTool instead. PwnageTool will not update your baseband.

Step 3: After jailbreaking, go to Cydia and search for “UltraSn0w”. Download and install the app, then reboot your iPhone.

That’s it. Your iPhone should now be unlocked.

If you use T-Mobile, make sure to turn 3G OFF in your iPhone settings.

  • Pedro

    Hello,

    by mistake I upgraded my iphone 3gs to IOS 4.3.3, with this upgrade my baseline was also updated to 05.16.02. To run my iphone I also need to unlock it, I read on some foruns tha I have to downgrade the version using Ipad’s baseband. Can you please tell me if by doing that change I will loose GPS?

    Thanks!

  • Nigel

    no you will not however you will not be able to upgrade or downgrade ever once you install the ipad baseband 🙂

    • khela

      i have ipad basebands and i update and downgrade with my saved shsh blobs easily iphone 3g

  • Alex

    hi do you know how can I unlock my iphone 4 whit the baseband 04.10.01 …..?
    Thk very much

    • PHETSOMPHOU

      hello iphone 4 update to 4.3.2 the baseband 04.10.01 can not unlock, do you no how to unlock, let me know

    • josefiyano

      Gevey sim is the only solution…

  • Houssein Joumaa

    i have 5.13.04 modem firmware and i did tried ultrasnow but it didn’t work

  • cripo

    NEED HELP

    i have a 3gs 4.1 jailbreak with limerain firmware 05.14.02
    i downloaded ultrasnow 1.2.3 and all says is searching then no network
    it works on orange and lookin it on 02

    • while jaibreaking click install cydia and install ipad baseband
      note: jailbreak using redsnow0.9.7b6

  • John

    Hi, I have moved out of the US and need to unlock my I-phone (3GS running on the 4.3.3). The problem is I have a 15.16.02 baseband. Is there anyway to unlock this phone or do I now own a paper weight? Also, if I can’t unlock it now and we are just waiting for the next fix and does anyone know what kind of timeline we are looking at until its release?

    Thanks

  • Maria

    Seb please reply…when will i be able to unlock the 05.16.02 baseband…?

    • davud

      if your iphone 3gs.
      – first downgrade your firmware to 4.2 or 4.1 with pwnage and restore with itune with holding ‘option button’ choose the custem restore that you did with pwnage.
      you will get error massage but thats fine. still work. use ‘tiny unbrella’ connect your phone and click ‘exit recovery’
      – use redsn0w and choose FW 4.2 or 4.1 and choose install ‘Ipad baseband’
      – unlock with ultrasn0w in cydia

      * after you success and want to upgrade to FW 4.3.3 WITHOUT upgrade baseband.
      – use redsn0w and choose ‘DFU’

      if you got problem just let me know! good luck

      • davud

        one more thing, I hear an issue with ipad baseband, GPS doesnt work. at my case, GPS works fine even with ipad baseband. for those who have problem with GPS with ipad baseband, MAYBE should try reinstall. who knows works again?

  • davud

    just wanna share info: for iphone 3gs if your firmware is 4.3.3 and baseband 15.06.02 you can still unlock. I did it and worked.
    1. downgrade your firmare to 4.2.1 or 4.1
    2. using redsn0w, install ‘ipad basband’

    tool to do that: redsn0w, pwnage, itunes

    • davud

      and tiny unbrella

  • Mani

    I have an I phone 3gs , 4.1 with baseband 05.15.04, How I can jailbreak and unlock this, Please help me

  • duck

    hi
    this unlock is not working in my iphone 4 .3.3

  • Hem

    Hi,

    My iphone 3gs is unlocked with Redsnow and is running 4.2.1. It is running 6.15 baseband now. It is a tethered jailbreak. Every time I reboot the device I need a computer. I want to move to 4.3.3 so that I get untethered jailbreak. Can I go for 4.3.3? Will there be any issues as I already unlocked my iphone? Can I do it with snowbreeze now instead of redsnow?

    Thanks,
    Hem

  • C4

    can they put a flash player code in to the jailbreak??? just want to know..

  • axel Macintosh

    gevey sim save my life

  • maec

    does anyone know, whether someone is trying to bring any possibility tu unlock basebands higher than 5.13.04??

    Is our waiting useless or not? There are many poeple who f*cked up this and upgraded their baseband, someone should care about them too..

    • maec

      I meant besides that useless iPad baseband..

  • jan

    hi
    this unlock is not working in my iphone 4 .3.3

  • Jasper

    i have an iPhone 4 with baseband 04.10.01 so it cant be unlocked.
    i use gevey sim, but i can’t make use of internet? only when i have wifi avaible.
    does anybody know how to fix this?
    thx..

  • John

    Hello Guys
    Where can I find ISO 4.3.3 for Iphone 4? I have downloaded it from this site by following instruction, but when unrar/unzip there is no file for IPSW…Any help would appreciate.

  • Mark

    Hi, i got my iphone 3gs from ebay. It is on 4.3.3 on baseband 05.16.02 yawn!!!
    I know there is a way to put it onto ipad baseband and i see there are extensive instructions on this but if i waited patiently, will there be an opportunity in the future to upgrade to higher baseband than 05.16.02 but supported by ultrasn0w enabling me to unlock but so i dont have to worry about using stuff that will stuff me up l8r on by not allowing me to upgrade or downgrade ever again, if you can understand my waffle???

  • maec

    Hey Mark, that is exactly my problem.. but looks like we are in a deep shit..

  • liam

    i have a 3gs firmware 05.16.02 i just jailbroken it, i followed the steps for cydia to unlock, but the phone bar keeps saying “searching….” and its been a while now, my sim is t-mobile, and i did turn off the 3g in the setting, did i do anything wrong or should i keep waiting, i also tried the turn off and on airplane mode and right now im still waiting dead bored

  • baseband

    You have same problem as me i have the 05.16.02 baseband, and they cant unlock it….hope they will sometime…just wait, do not use the method with the ipad baseband coz you will get a lot of errors

  • naji

    any new news about iphone 4 bb more than 1.59.00

  • FoxTrot

    I have an iPhone 3GS with ATT carrier 4.3.3/05.12.01. (New Carrier FIDO) (custom firmware build by pwnage tool 4.3.3.1) I follow the how to with success. The SIM is recognise (carrier/IMEI OK) but I have an No Service issue.
    The SIM card work fine in my old phone.

    Any suggestion please

  • Melzer

    When I upload the ultrasn0w it says “could not activate cellular data network” I have a 4.3.2 / 05.16.02 formware. It was on an At&T iphone and I am trying to unlock it to tmobile.

    I have no idea what I am doing wrong. It also says “searching” and never connects. I am so frustrated!

    • Ryan

      the base band 05.16.02 isn’t supported yet, you can upload the ipad baseband and then do it and it should work but some people are having trouble with that. read all the comments above and it should give you insight on how to fix your problem.

      Hope that helped.

      • Victor

        I have an Iphone 4 version 4.3.3 and baseband 04.10.01 it is already jailbroken but canot unlock, can anybody help me. thanks

  • Saad Gz

    Guys any news about the Ultrasn0w 1.3 ? Cuz I’m TIRED of searching, and I’m tired too of keeping my Iphone with me just like an Itouch =/
    I got it on 4.3.3 with the Baseband 3.10.01

  • m7md

    I am new to this ultrasn0w thing !!! my question is simple….

    does ultrasn0w make your iphone simfree (any sim in the world ) ?

    thank you

  • Richard

    Well it was my day off today and I completely stuffed things up. My first Iphone 3GS not new from ebay. So many years waiting to buy one…. Suppose to be on my network but was not. Managed to Jailbrake it but in the process did not understand the importance of Alt when restoring so there you have it Firmware 5.16.02 and V 4.3.3. Six hours later I am here.

    A message to all you techie people. If and when you come up with a solution for average people like me you will make a lot of people very happy. Really. My cute but masculine Iphone will live and I will walk down the road, back straight, head held high, smiling the smile of a man with an iphone and apps and email . What Joy.

    I fact I will be so happy I will make donation to this communities favorite charity. ( reciept posted on line ) Bribery? No. My way of demonstrating that good begets good and spreading the joy.

    Richard

  • Larry

    I have an Iphone 4 version 4.3.3 and baseband 04.10.01 it is already jailbroken but canot unlock, can anybody help me. thanks

  • shopA

    I want to carrier unlock my iPhone 4, but do not need rest of the jailbreak features. If I jailbreak, then unlock using ultrasn0w, and then reconnect to iTunes, which will make the jailbreak go away, will my phone still be unlocked? Thanks.

  • Pello

    Hey

    I have an iPhone 3GS with baseband 15.16.02 on iOS 4.3.3 and I know about the downgrade to iPad baseband, but that isn’t actually very compatible.. Any idea how long it will take for a good unlock for the version?

    THanks

  • Khuram

    hi do you know how can I unlock my iphone 4 whit the baseband 04.10.01 …..?
    Thk very much

  • Eric

    Hi, i have an iPhone 3G, Version 3.1.3, Baseband 05.12.01, Jailbroken and Unlocked witch i use in Venezuela and i want to update to 4.3.3 but i’m afraid to mess my phone, so could you please tell me step by step how to do it?. I have read so many times people who did it the wrong way and cannot unlock their phones.

    Thanks for your kindly help

  • ddogg

    Will there be 4.3.4 ver. with base 5.16.02 unlock coming soon? If not, would it be hard to downgrade to 4.3.3?

  • ddogg

    Will there be 4.3.4 ver. with base 5.16.02 unlock coming soon? If not, would it be hard to downgrade to 4.3.3?

    Thanks

  • Josh

    Ok. Someone break the news to me. Am I stuck on BB 05.15.04 FOREVER?! Because I sure as hell won’t upgrade it to 06.15.00. So please, as of today, is it possible to unlock an iPhone 3GS iOS 4.2.1 with BB 05.15.04?

    PLEASE HELP ME.

  • michelle

    hi! had my iphone 3gs upgraded to 4.3.3 BB 6.15, a few hours after jailbreak it was ok then all of a sudden my fone displayed no service. been trying to fix it but i cant. can someone please help me? thank u. 🙂

  • sunny

    will there be ultrasn0w unlock for 4.10.01 ever?

  • Paul

    Hi,

    I have a 3GS JB on 4.3.3 and 06.15.00BB and i’m having some problems with the GPS signal.
    Any idea how to fix this?

    Thanks

    • Josh

      That’s exactly one of the few issues upgrading to BB 06.15.00 had. There is no fix for it, as that baseband is permanent and cannot be downgraded (for now).

  • MiraOSLO

    Hi, I have a strange problem with my 3GS 4.3.3. bb 6.15.00

    I jailbroked and unlocked (switced to 6.15) without a problem, no lost of GPS or anything.
    I did that 2 moths ago in Norway were I live.
    For the moment I’m in Frace, and the minute I landed the phone didnt have network anymore. I searched for carriers and found 3 (Orange, Bougyes and SFR), the ONLY network that worked was Bougyes, I had full signal and all, BUT I couldnt call/recive or sms. Internet gps and all still works.
    I rebooted, reintalled both ultrasn0w and Carrier Reset fix (cydia.pushfix.info) numbres of times, and still didnt work.
    I thought maybe the phone was confused using a norwegian sim card (Lebara) and choosing another carrier cause of the country, so yesterday I bought a sim card (Orange). And still nothing worked.. Through General –> About it finds both Lebara and Orange in Carrier when using/changing the simcards..
    What can be wrong?

  • emmanuel hinson

    I have an Iphone 4 version 4.3.3 and baseband 04.10.01 it is already jailbroken but cannot unlock, and i dont have any Gevey sim booster around me. can anybody help me please. thanks

    • Josefiyano

      Where is your location?

    • Josefiyano

      Where is your location

  • sunny

    ultasn0w pls help us from gevey sim

  • jagoff

    got this to work. t-mobile sim in 3gs on 4.3.3 with ultrasn0w 1.2.3 and BB 6.15.00
    it would not work with BB 5.16.00x
    nuff said.
    my problem is that I must keep booting tethered with redsn0w after reboots, or the phone goes to DFU mode. Any fix for that?

  • BigBoss

    Guys need your advice. I have a 3GS Jailbroken and Unlocked. Currently i have the IOS version 4.2.1 and the modem Firmware is 06.15.00 I have GPs signal with TomTom car kit. I’m fine.

    I’m thinking about upgrade to 4.3.3 Software but i’m affraid to loose the GPS feature since i use this a lot. Can anyone tell if i can upgrade to 4.3.3 without loosing the GPS feature? Remember i’m already unlocked and with 06.15.00 and gps works good for me.

    Tnx.
    -Jorge

  • Paul

    @BigBoss

    I have my 3GS JB at 4.3.3. with 06.15.00BB and neither TomTom nor Ndrive GPS works.
    Most people believe is a BB isue, but since yours is working i would say is a 06.15.00BB + 4.3.3 Firmware problem

    Cheers

    Paulo

  • BigBoss

    Thanks Paul. Well my iPhone has no GPS signal at all without the TomTom car kit. With the Car kit i get full GPS signal. So my question is… is the TomTom Car Kit making the difference or it’s definitely a problem of the 06.15.00 band + 4.3.3 firmware?? Hoping someone with the TomTom car kit and the 4.3.3 Unlocked – Jailbroken iPhone can reply.

    Tnx.

  • Ehab Ahmad

    An ideas about the release of the software unlock for iPhone 4, 4.3.3 baseband 4.10.01?
    Gevey sim sucks! I’m using it till the moment, since I’ve no other option…
    Would it be easier if I updated to 4.3.5?
    Help, please!

  • maec

    Guys, I already found one great, the only one and best solution!!!

    I switched to Samsung and Android as I couldn’t stand this shit. I recommend you the same (in case you have some spare money, just buy a new phone [not iPhone]).

  • JP

    I never updated my iPhone 4 past 4.3.3, but it turns out I have 4.10.01 Baseband. How did that happen? Here I was, preserving 4.3.3, but I still have newer baseband. The phone was bought in April, could it have started with 4.10.01?

    Is Apple updating baseband over the air?

  • Dj

    Haha so…
    Idk if ne one can help… My phone was “bricked” so I thought. Got luck with the ressn0w 9xxx7c and i think i used pwnage first then restore then redsnow.

    OK ok so the problem is that I am un”bricked” at 16.15.00 baseband (ipad) and on 4.1. Ive got cydia installed ultrasnow bla bla but When i insert my tmobile sim card it gives me no service message. Without it says no service. I have a att sim tried that…no luck. So what do I need to do. I read this whole forum one person made it sound like I may need to update to 4.3.3 with pwnage, then redsnow again withthe 4.3.3 using redsnow 9xxx8c?? I think. Idk but I really am not looking forward to the potential of bricking this phone again. I have plenty exp jail breaking and unlocking. this is my second stump (first one was hardware issue caused from….to much jailbreaking/flashin lol)

    • hi do u know how to downgrade frm 4.3.5 to 4.3.3

      im dileep frm india
      9666638000

  • hai frnds

    is ther anyone to help me that how to unlock iphone 4

    or how to downgrade from 4.3.5 to 4.3.3 or 4.x