Famous userland jailbreak hacker @Comex has just tweeted some interesting information regarding the status of i0n1c’s iOS 4.3.1 untethered jailbreak exploit.

According to @Comex, i0n1c’s untethered jailbreak kernel exploit used in redsn0w to jailbreak iOS 4.3.1 doesn’t seem to be patched yet in the new iOS 4.3.2 released earlier today…

By the way, iOS 4.3.2 is (as far as I can see) still vulnerable to @i0n1c‘s untether vulnerability.

At this point in time, the Dev Team has advised jailbreakers and unlockers to stay away from the iOS update, until they’ve thoroughly tested it to see if its safe.

Correct me if I’m wrong, but it seems that those of you that updated to iOS 4.3.2 today were only able to get a tethered jailbreak, leading us to believe that Apple has indeed patched i0n1c’s untethered kernel exploit from iOS 4.3.1. But that may not be the case. If Comex is right about iOS 4.3.2 still being vulnerable to the untether vulnerability, it might just need to be updated to support the new firmware. Keep in mind, this is pure speculation on my part.

As always, we’ll keep you updated when we hear more on the subject!