Hot off the heels of the new iOS 4.3.1 untethered jailbreak, there seems to be word going around that the jailbreak causes WiFi issues.

@i0n1c, the hacker who found the untethered kernel exploit for iOS 4.3.1 which the Dev Team intergrated into the RedSn0w jailbreak utility, clears up some confusion regarding the WiFi issues…

i0n1c mentioned via Twitter that the one of the reasons the RedSn0w/PwnageTool utility had been delayed was the mysterious WiFi issues. Later on they found out it wasn’t the jailbreak that was causing the issues, but rather the new iOS 4.3.1.

BTW: One of the reasons why the PwnageTool + RedSn0w tool was delayed was do to the mysterious WiFi issues. Turns out the issues also occur without a jailbreak.

According to i0n1c, the issues can be resolved for some iPhone owners by simply rebooting the router.

Are you experiencing WiFi issues on iOS 4.3.1? If so, drop us a line in the comments!

  • Nathan

    Yes I have, it’s just so slow!

    • Abu iPhone

      Well did ya reboot the router?

  • Sotoy

    No wifi issue here… my wifi is running normal on my i4 4.3.1, BUT its only one bar for ATT signal :p . My device is iPhone 4 fw 4.3.1 bb 02.10. Now Im downgrade back to 4.2.1 which is better IMO. I hope the can fix the 1 signal bar issue. 😉

    • BlueRaider

      I am in the exact same boat as you! My phone has not had over one bar since I ran the JB. I’m also on BB 2.10. and I wonder if that has something to do with the reception issue?

    • ahmed al-khuzae

      same here ,,
      only one signal bar . no problem at calling though

      and the wifi is normal

  • Burge

    I’ll let you know later…restore and jailbreak tonight ..still at work ..good to know there could be problems though even if it’s not the jailbreak ..

  • Jon Garrett

    this is why I never update in the beginning, I wait to see what problems there are first AND make sure all my favorite Cydia apps work.

  • ir0nic_r3b3ll

    Apparently ios 4.3.1 consumes more memory than 4.2.1 on iphone 4, sbsettings shows my free memory around 289 mb whereas on 4..2.1 memory was around 359 mb.Huge drop!!

    • hgfdasgjhg

      theres a reason iPod Touch 2g and iPhone 3g got thrown in the trash.

  • Psychlloyd

    I’m not jailbroken and have had wifi issues since 4.3. Connection is present and fast when tested with speedtest.net app but cannot get apps like Twitter and Facebook to work without switching off to 3G.

  • Adam

    This has been happening for me for ages! Around a year or so!!! Ive used 3 different routers and still experience problem! (its not isp either)

    • Galen20K

      Same here, its really an annoying occurrence that should NOT happen. I spend 400 dollars on an Apple product and I expect it to actually WORK and not drop my Wifi so damn often. Apple seriously needs to do something about this if they expect people who have had these issues to buy their products in the future. What good is an Elegant, “Magical” product if it doesn’t work as expected and isn’t reliable??

  • babeh

    Maybe related to QoS Service,
    try shut the QoS off on the private router interface.

  • azharhamzahya

    I’ll wait for a while until the Dev team solve the problem

    • Burge

      It’s not the jailbreak it’s iOS 4.3.1

  • DarkSeTT

    Jailbroken this morning and havent expirience any problems yet and have downloaded a couple of apps fron installous with normal speed and concistency. Jb ipad 1 new 4.3.1 with redsn0w windows.

    • DarkSeTT

      Consistency*

      • Santa

        Redsnow jailbreak ipad 1? The redsnow tutorial say nothing about ipad. I recently receive an ipad 1 with 3.2.2 firmware and i have jailbreaked but i can’t upgrade to 4.2.1 because i don’t have shsh on cydia. I must upgrade to 4.3.1 but there is not jailbreak for windows.
        Scuse my poor english, its not my native language.

      • DarkSeTT

        Santa, the tutorial is some days old but this jailbrake is for all the devices with 4.3.1 (not incluted the ones listed as tethered). If you have the appsync make a backup on itunes (and the cydia files if you can) and restore. Then jailbrake following the instructions and with the .ipsw. I did it with my 4.3.1 ipad 1 without problems.

  • Faceted Phoenix

    I would appreciate a reply to this please. I am on an iphone 4, AT&T, 4.2.1, baseband 03.10.01. I want to unlock my iphone so I can use another carrier internationally. Which unlock will allow me to this. Thanks!

    • zbegon

      Currently no unlock for that baseband.

  • XepptizZ

    I thought i read somewhere on this site that two routers with he same name on the same wifi can cause the iphone with normal ios 4.3 to freak out. The fix was to change the routername.

  • Marsh

    I am having an issue with my iPad 2 using WiFi while listening to some radio stations. I did reboot the router.

  • So can I Jailbreak My iPhone 4 With RedSnow & 4.3.1 Or Not?

  • DarkReign

    I have an IP4 and used the RedSnow JB for IOS 4.3.1… i connected to the router and started downloading apps and games via installous but to no good, downloads are failing one after the other. i observed the behavior and noticed that the wifi is being disconnected when the wifi list is being refreshed. i did a side by side observation with an IP4 of my friend that is not jailbroken and using IOS 4.3.1 as well, and hell yeah… there’s a problem with my wifi connection. on his IP4, when the wifi list is refreshed, it is still connected, as for me, it’s loosing its connection… hope someone could help me. already tried rebooting the router, the same thing happens.

    DarkReign

    • Crazy2hack

      Have you found a fix for this yet I have the same issue

    • Crazy2hack

      Have you found a fix for this yet I have the same issue?

      • Kickstar13

        Upgrade to iOS 4.3.2.

  • Joel

    no cydia internet access til router reboot. fine now. ipt 4 / win 7

    • Joel

      i have had to reboot router alot after using public wifi and returning home since 4.1.

  • Lucas K.

    I have had issues on my wifi w/ iPhone 4 since 4.1 jailbreak on a Netgear router… no problems on our laptops and my iPad though, so I’m assuming it’s just my phone maybe…

  • Jim

    My Wifi has not changed.
    Since 3.0 my WiFi signal has gone up and down.
    I had 2.2.1 on one iPod touch and 3.0 on another. 2.2.1 was always strong and fast and always had full bars. 3.0 signal strength bar went up and down like a temp gauge.
    I showed this to Apple and they said it was my router. Apple extreme is what I am running. Checked it at their store on their network and had the same problem. The problem is in ther iOS 3.0 and up. Apple are is in Denial.

  • Bob

    Guys, the dev tells you that I’d you jailbreak 4.3.1 and don’t upgrade the bb you will only get one signal bar.

  • koes365

    Is the wifi issue when tethering only or when trying to join a network to. because i dont tether but my wifi is working fine on 4.3.1 on ip4…also sum apps and tweaks on cydia that worked on 4.2.1 is NOT working on 4.3.1 also a couple repose.. are coming up withe errors when loading cydia……

  • Keetveter

    Wifi doesn’t automatically conect to known stations after 4.3.1 with JB. Didn’t try without. Haven’t rebooten my router yet and also haven’t my iphone rebooten. I will try that now.

  • topi

    No issue here, everything is running as it should on every router i m working with.

  • Keetveter

    Problem for me solved.

  • duane

    iPhone4 using wifi at the office and at home. 3G (Telus) other wise. It used to switch automatically to wifi networks that I had configured with username and password. Since installing 4.3.1, it stopped doing this. I can usually manually go to the wifi section and when I open it, it populates a list of connections. Choosing one usually works.

    Sometime it seems to drop though and it never did that before. I’ve had to disable cellular data so that I’m not watching a hockey game at home on 3g by mistake.

    I’ve rebooted routers etc. but no help. My son has an ipod 3 that hasn’t been updated and it works as always on the same network.

    Is this a known problem?

  • xman

    Yes, WiFi problem, but resolved by rebooting router.

    I found this page when I experienced problems after upgrading to iOS 4.3.1 + jailbreaking. Pinging the iPhone showed terrible packet loss. After a reboot, no packet loss anymore.

  • Max

    I have wifi problem after upgrading to 4.3.1 and jailbreak with redsnow. I tried to reboot my routor (d-link 628+) and the problem is still there… Does anyone knows what can i try

  • Nellos

    Router dgn2000 i have wifi problem with this netgear router

  • Trintin7

    I’m using 3GS and on JBios4.3.1 and have wifi dropping issue.
    This happens almost every few pages loaded in safari I have to keep re-connecting to the network. Hope Apple release the fix soon

  • taha

    hi..i installed custom ios 4.3.1 on my iphone 4 but i have wifi disabled..no bluetooth…no bb version n even no firmware version….m stuck badly…plz help

  • Fred

    Upgraded from 4.2.1 to 4.3.1 and JB’d and I could not connect to WI-fi at all. Whilst they would bee seen, I could not connect. I also lost all of the installed script packages and mobilesubstrate. I wiped the iphone and did a full restore and jb’d a clean 4.3.1 system: no issues at all.

    (although using scrollingboard and opening up folders and selecting apps to delete causes system freezes which is longer than 4.2.1)

  • Stans

    I am having Wifi issues as well . My Wifi is searching but only for a few seconds then it stops and restarts again never locating any hotspots. I did not reboot my router because I have two and another phone that I use as a hotspot and it would not locate neither device. I tried it at work today and the results were the same. NOTHING

  • Kim

    Try “forgetting” your existing wifi network (under generL)
    If that doesn’t work, reset your network settings.
    Reset router as well… Restore your phone.
    Trial and error to find the actual reason why the wifi is dropping…
    I “forgot” my network and re-entered it and so far it seems to be working.

  • Geo

    We have two ip4’s
    Mine will not connect to my home wifi (though it shows it is connected) since updating to 4.3.1 and now 4.3.2. Works elsewhere and worked fine prior to the updates. Hers works fine at home but is running 4.2.1. This is with a cisco valet plus.

  • Cathy

    Most image forensics are done in a way called “copy and paste”, which means part of the image is copied from another part of it. A site named Photoshopped Image Killer can detect such kind of image forgery very well. It identifies the forgery by detecting repetitions in the digital bits that comprise the imageeven if those repetitions are too subtle for the eye to detect or damaged by image compressions like JPEG.

  • John

    I have an iPhone 4 32GB running iOS 4.3.2. WiFi drops out for 2 seconds every 10 seconds. Have reset router, “Forgotten” that connection on the iPhone and reestablished it, powered down the iPhone. So far nothing seems to make a difference. Have read many other accounts of identical issues everywhere but on the “official” Apple user forum. No solution has been successful

    This phone is just outside the “generous” 90-day support limit imposed by Apple so I would like to avoid contacting them and having to pay them to fix their faulty device!

    I have 3 iPhone 3Gs 32GB units running just fine on the same wireless network (Netgear WNDR3700 router).

    Anyone out there have a real fix for this issue?

    • Mfrooty

      I will tell you how I have fixed wifi issue for my iphone 3gs 4.3.1
      I remove the security from the router (remove user name and password)
      and I use the MAC address filter for security instead of user name and password and its working fine.
      try this and let me know if its working.

  • judyg21

    I was having wifi connection problems…my internet on my MACs and PCs would be running fine, then all of a sudden I would lose internet connection. When I restart my router the internet connection would be working again…only to lose connection after a while. During this whole episode, the 3 iPhone 4s in my household were not able to connect to the wifi network (prior to this whole situation, they were connecting just fine). I noticed that each time I got the wifi network running again, it would stop working when an iPhone 4 tried to connect to the wifi network. So the problem was definitely the iPhones. What I did was reset the network settings on the iPhones by going to Settings > General > Reset > Reset Network Settings. This resolved the problem for me once and for all.

  • karen

    I’ve tried the settings>general>reset>reset network settings three times and still not wifi connection

  • i am facing issues in WIfi. it connects sometimes, then at times it doesnt recognize the wifi