It’s here, folks. After weeks of anticipation, the Dev Team just released an untethered jailbreak for iOS 4.3.1. This jailbreak is mostly due to the untether exploit found by i0n1c.

This jailbreak works with every device that supports iOS 4.3.1, except for the iPad 2. So to be clear, this jailbreak will work with the iPhone 4, iPhone 3GS, iPad 1, iPod Touch 4G, iPod Touch 3G, and the second generation of Apple TV…

The Dev Team released 2 versions of the iOS 4.3.1 jailbreak. You can now use PwnageTool to jailbreak your iPhone while preserving the baseband (Mac only), or you can use RedSn0w (both Mac and PC versions available).

If you rely on the UltraSn0w unlock, it is recommended that you wait for the Dev Team to update this tool before upgrading and jailbreaking.

ultrasn0w users don’t update yet! We need to first release an update to ultrasn0w that fixes some incompatibilities when FW 4.3.1 is used on the older basebands supported by ultrasn0w.  And remember once we do fix ultrasn0w for 4.3.1 (we’ll announce it here and on twitter), you must only get there via a custom IPSW from PwnageTool, Sn0wbreeze or xpwn!  Don’t ever try to restore or update to a stock IPSW, or you’ll lose the unlock!

You can download PwnageTool 4.3 and the RedSn0w 0.9.6rc9 jailbreak from our download section. If you’re not sure how to use these tools, make sure to check out our PwnageTool tutorial and our RedSn0w tutorial.

  • Henryboi

    im on baseband 06.15.00 on iphone 3gs. do i need 2 unlock again after updating to 4.3.1

    • Reytube

      Do not upgrade or else you’ll be stuck to apple logo.

    • wlj3004

      yes, you need to unlock again.

      no, you cannot update to 4.3.1 using pwanagetool/redsnow yet due incompatible ultrasnow to the fw 4.3.1.

      just wait for the announcement from dev team.

      • p51-74774

        i got a 3G with 4.2.1 and 6.15.00 baseband to unlock with T-Mobile SIM. the phone will only resolve an Edge signal. is this because of the baseband or T-Mobile’s network not allowing to use the 3G network?

    • igeek

      BUT NO UNLOCK…. HMMMMMMM

  • Yes finally!!! now I can update mine to the 4.3.1 🙂 thanks guys! and you Sebastien for daily updates! good luck

  • Rainrose

    Yesss so excited to jb tomorrow! I can finally update to 4.3.1 Million thanks to the Dev Team! Xoxo

  • afzal merchant

    THANKS A TON DEV TEAM….

  • Huey

    Is “RedSn0w 0.9.6rc9” the latest version I should be using?

  • Sadness

    hey i have an iPhone4 and imm on baseband 03.10.01 and iOS 4.2.1… will i be able to jailbreak AND unlock my phone?…

  • apeoj

    hey wich verion of redsn0w i need to download

  • BLiNK

    for me, no need to update until LockInfo is ready

  • Sweet. Now just for iPad 2 please

  • Reytube

    Do not upgrade or else you’ll be stuck to apple logo. And people this is not an unlock, it’s for jailbreak.

  • Ivo

    What about the i pad 2?

  • Beakhand

    Anyway to do this without putting it into dfu mode my power button is broken please help

  • Ivo

    What about the i pad 2

    • BLiNK

      nothing. you, and others, will have to wait

  • Ck

    4.3.1 jailbrake doesn’t work on iPad2, but i have iOS 4.3.. So, why cant jailbrake ipad2?:@

  • CkStar

    4.3.1 jailbrake doesn’t work on iPad2, but i have iOS 4.3.. So, why cant jailbrake ipad2?:@

    • Beakhand

      There is no jb for 4.3 only 4.3.1 even on iphone

  • Dan

    On the Dev-Team Blog, they specifically mention that the “iPhone4 (GSM)” is compatible with this jailbreak. This makes me think the Verizon iPhone 4 is *not* compatible. Does anyone know if this is true or not?

    • Dan

      Err, nevermind, 4.3.1 isn’t available for the Verizon iPhone 4 yet.

      • Anonymous

        You can’t unlock a CDMA phone anyway, there is no sim card.

  • carlton

    thanks so much

  • StX

    Sebastien, aren’t you on your Honeymoon??? That’s Dedication!!!

  • Ja808hi

    Much Mahalo from the islands. thats for the hard work

  • Paul

    Just jailbreaked my white iPhone 4 with 4.3.1 stock firmware using RedSn0w 0.9.6rc9, it working like a charm! Nice job 😉

  • Ja808hi

    wich verion of redsn0w for windows do i need?

  • David Dee

    My gosh. Waiting for this so long time. I accidentally upgraded my 3gs 4.0 to 4.3.1
    Waited so long.

    • moimoimoimoi

      what a month? dumb kids.

  • Saz

    I’ll wait a while.

  • Dude

    hi Guys,
    i am a bit new with using iphone – i have iphone4 and recently updated to 4.3.1
    do not know what is my baseband or firmware – ( modem firmware is 04.10.01) and version is 4.3.1 (8G4)
    can any of you guys tell me how do i jailbreak my iphone ?
    what softwares would i need and how do i go about it — would be a great help guys.

    Thanks,
    Dude

    • Joey

      you can use redsnow or any of them you will be able to jailbreak the phone but not unlock it

  • Wikan

    After jailbreaking and preserving baseband only 1 bar shows on my network constantly. The phone works, calling texting so it’s no biggie. Anyone else had this problem. Running iPhone 4, jailbroken with PwnageTool baseband version 02.10.04 ?

    • Kentaurus

      I have the same problem with baseband 1.59.0 on 4.3.1 with Telekom in Germany.

    • Chris

      Hi, I am having exactly the same problem. Is there any solution to resolve?

    • Enrique

      having the same problem. any fix yet?

  • Dude

    it is unlocked from etisalat .. service provider in dubai,
    i just need to jailbreak this but i do not have a mac system so how do i use Pwnage tool ?
    can i use it on windows ??

    Rgds

    • wlj3004

      just use latest redsnow.

  • wlj3004

    Great job Dev Team. Even though the jailbreak has it limitation.

    At least, the Dev Team has something to give to the iphone community.

    And one thing that I realize, the jb scenario getting harder and limited to its function.

    Anyway, thanks Dev Team for make our idevices wild again and again.

    • MOrrow8h

      Just out of curiosity, what limitations r u talking about?

      • Tricksh0tz

        Things like ALSR security maybe and ofcourse exploits that are closed / new bootroms in ipad 2

      • Wlj3004

        Well, no newer unlock yet.

        Mac only jb tools (personally i am not into snowbreeze – in jb & retain the old baseband)

        Incompatible ultrasnow at the moment with fw 4.3.1

        Ipad2 not included

        Still no solution for gps fix (baseband 06.15.00 (after all, users fault)

        Regardless the limitation, the jb release are great relieve for iphone community.

  • azharhamzahya

    TYVM Dev team and iDB

  • ken

    im on baseband 01.59.00 on iphone4 4.0.2. do i need 2 unlock again after updating to 4.3.1

    • wlj3004

      of course.

      but, u need to wait for dev team announcement first.

      ultrasnow not compatible with fw 4.3.1 yet.

  • Knatch1&2

    Thank you for the jailbreak, awesome stuff 🙂 I’m a novice on this but I’ve run into a problem, I can’t make any calls or send messages from the iphone. Does anybody know what the problem might be?

    I saw that Wikan and I had a similar problem.

  • Del_

    Jailbroke iphone 4 using Redsn0w 0.9.6rc9 all went smooth, loaded my tomtom but it’s saying poor GPS. As anybody else got the same issue?

  • Amykat

    I have an iPhone 4 ios 4.0.1 jailbroken (I never updated bc my friends had issues and mine has been fine). I want to upgrade to 4.3.1 and jailbreak. If I update through iTunes, and jailbreak using redsn0w, will I lose all my apps? (some are from installous) and cydia files? Is there a way to back this up/restore? How? Any help is appreciated!!

    • wlj3004

      First of all, do u use ultrasnow for unlock? If u do, do not upgrade yet. Wait for dev team announcement.

      If u use official carrier or u have factory unlock. U can follow the step i normally do.

      1. Backup and sync the iphone. Make note all cydia apps u have installed for manual installation.
      2. Upgrade the iphone to fw 4.3.1
      3. Do not restore the backup or sync after upgrade. Just set up as new phone first.
      4. Jb the phone using latest redsnow.
      5. Install all cydia apps u have before.
      6. Now, u can restore the backup u have made just now.
      7. Walla, new fw with recent apps & setting.

      Enjoy.

      The reason i didn’t use pkgbckup, it crash a lot.

  • raj

    After jailbreak Ipod function not working on iphone 4
    can anyone help?

  • hiru tokyo

    Why I can’t upgrade my iPhone 3gs 4.2.1 to 4.3.1? error 1015.. stuck to connect to itunes.. I have a baseband 06.15.00 which is ipad baseband. jailboken by greenpoison.

    • Wlj3004

      It seem you’ve use tinyumbrella to restore or downgrade your iphone before this.

      Do you use mac osx or windows?

    • lubs

      I have the same issue. 3GS, 4.2.1, 06.15.00, except jailbroken with redsnow 9.6b5.

      Stuck at Connect to iTunes 😐

  • JailBreak Dude

    I upgraded to 4.3.1 with my Iphone4, i’m going overseas, is the Ipad base band 06.15.00 compatible?
    And if it is, can you provide me the link?
    I successfully unlock my friend’s Iphone4 with 4.2.1 and used the ipad base band 06.15.00, he knows the consequences, but he rather wanted to use his Iphone4 in Japan
    Thank you.
    Jm

  • Eric

    Hey I’m new to the iPhone jailbreak and stuff, and I have an iPhone 4 – 4.2.1 and I jailbroke it using GreenPoison. And I want to upgrade my phone to 4.3, so if I do, will I still be able to use installous to download apps? I download all my apps using installous.

  • hola to all i got iphone 4 i need to unlock it its on 4.3.1 but baseband is not 6.15 how do i make it 6.15 so i can unlock it

  • Sjaak

    How can i jailbreak my iPod 4.3

  • Kenya Lee

    Redsn02 doesn’t want to download for me. I click on the link and it says page not found. Help?

  • Anup

    Hello Friends
    I am new Iphone user. I have Iphone 4 White 4.3.1 and modem Firmware Version 04.10.01.
    what should I use to jailbreak and Unlock the phone? basically I am not that fan of using Iphone by my self but I bought it for my sis in India, and jsut want to make sure when I give her it will work with her sim. plz help.