One of my Twitter buddies sent me a screenshot of an error he is currently getting on his iPhone when trying to download a certain application from the App Store. Every time he tries to download VLC, his iPhone tells him that this application is not compatible and that he needs to update his iPhone to iOS 3.2.

Obviously the strange part is there is no such thing as iOS 3.2. There never was and there never will. So why does his iPhone tell him he needs the 3.2 software update?

It’s worth noting that he’s got the first gen iPhone with software 3.1.3. I believe this is a minor bug displayed when an application is not supported by an older firmware. Instead of saying your iPhone requires iOS 4.1, your iPhone asks you to update to firmware 3.2 because it has no idea 4.1 is the newer firmware. Makes sense? I don’t think you’d ever see this on an iPhone 4 for example.

Have you seen this error message before? If so, on what iPhone model?