This morning I told you about a trick to install Frash on your iPhone. This can be a little cumbersome. My Twitter friend @egohot_dev sent me a tip that really automates the whole process.

Step 1: Make sure your iPhone is jailbroken. If it’s not, follow these instructions.

Step 2: Go to Cydia and install the following source: http://repo.benm.at/

Step 3: Install Frash from this repo.

Step 4: Reboot your iPhone. Done!

Much easier than doing it manually.

Let us know how it works for you.

  • Libyansolja

    N e solution to the gsc.armv7 prereq
    i got a 2g 3.1.3

  • I installed it on my iPhone 3gs running iOS 3.1.3 and when I press the “flash” button , I see a black pic and written “unexpected error” ;( tried to re-install several times.. Any one’s gettin it?

    • Rashid

      Yo guys i ll tell u simple thing . Donot add any kind of source like repo.benm etc. Just intall installous through cydia. Then install skyfire . now u can watch flash video. And now say thanks to me bye take care

    • Rashid

      Yo guys no need to add source like repo.benm etc just install installous through cydia and install skyfire and now watch flash video. And now say thanx to me bye take care….. Source=cydia.hackulo.us then install INSTALLOUS

  • RavenMad

    Installed on my iPod Touch 3G with iOS 4 had to reboot 3 times befor it started working but now it works great 🙂

  • 4ghipsterrr

    Still no luck, I’ll just wait for Frash.1.0.deb…….Comex. Help us!

  • mohgui

    managed to successfully installed on my 3GS with 4.0.1. thru Cydia.

    in the midst of loading the Flash content in Safari… it crashes. after rebooting the 3GS and reloading the flash site… i got “Socke error: Connection reset by peer”

  • Naomi

    “The requested modifications cannot be applied due to required dependencies or conflicts that cannot be automatically found or fixed”
    Depends: gsc.armv7

    Any solution? Maybe a creator could help. Any link to his/her site?

  • icyhotonmynuts

    Doesn’t work even after reinstall on iPhone 3GS 3.1.3

  • Merto

    Those with a 3G that get this error message when trying to install like this:

    “The requested modifications cannot be applied due to required dependencies or conflicts that cannot be automatically found or fixed”

    A friend of mine installed iOS4 and then it worked for him on a 3G.

  • Naomi

    @Merto
    I had iOS4 installed when the error occurred.

  • Raghu

    Please can any one tell me how to run flash games on 3gs 3.1.3. I tried but says unexpected error

  • casper

    3GS 16gb 4.0.1 didnt work… gsc.armv7 error

    all you have to do is update everything in cydia…than it should work 🙂

  • Naomi

    @casper. Nothing to update. Anyway, according to this site http://www.ipodtouchfans.com/forums/showthread.php?t=304543
    “It only works for the arm7 devices, i.e. from the 3GS onwards (not including new bootrom 8GB iPods)” and “…doesn’t support MC models”.
    The author should have included such message in the first place to save some time for people who don’t have arm7 devices, whatever it means, but it looks there are few of them.

  • Rhysd007

    download SBSettings, should eliminate the gsc.armv7 errors.

  • BLiNGDiNG

    Seems to have missed everyone’s attention that it clearly says in on the repo “this does NOT work for 2g or 3g !! Granted the font size aint the biggest but thewarnings deffo there!

  • Andu

    Unexpected error for every flash help please fix it

  • IT SAYS I NEED GSC.ARMV7
    tat is very annoying.
    i worked so hard jailbreaking my ipod souly to get some flash on it
    then i come to find out this crap !
    can anobody help me?!

  • GoldenZ

    Works for me in iPad 3.2.1 Thanks alot for sharing =)

  • GoldenZ

    Adrian@
    I recommend you to install Frash through the manual way! (install the deb files) Just Search in google with the keyword Install Frash deb

    Good-luck.
    Amr

  • chris

    For 3GS and Iphone 4 if you get error Dependence: gsc.armv7

    Install SBsettings and disable SSH and install frash from repo

  • Hussain

    It installed correctly but flash is still not working on my iPhone 3GS iOS 4.1

  • Sum

    Same Problem here. I get that same error “unexpected error”. Anyone with the solution.
    Please scroll down the page and post.

  • RAVEN

    ANYONE GOT E SOLUTION FOR THE UNEXPECTED ERROR IM USING 3GS.. PLS HELP GUYS… HAPPY NEW YEAR

  • Gabo

    Simply reebot, tris fide me

  • Chris

    It dosn’t work just tried a lot of different sites that require flash. ” _abort() food.c:43″ comes up every time even after multiple reboots 🙁 any better ideas anyone?

    • Chris, did you ever get help? We got the same error message. My phone is a 3GS. Just curious as sometimes when people get help, they then disappear. LOL. I know I do. Problem solved, move on. But alas my problem is similar as yours and I’ve not found assistance yet… So wondered.

      • Dan

        Did you guys ever figure out the solution to the “Unexpected Error” message?

  • Rashi

    I try on my iphone4 4.2.1 but It dosn’t work just tried a lot of different sites that require flash. ” _abort() food.c:43″ comes up every time.

  • My 3GS after Frash install still shows ‘Flash’ not the ‘F’ icon and when I click it says “abort () food…”. I found a place that says to make directory for var/blah blah autoinstall…but it seems for the iPhone 4. Any help with the 3GS install. I’ve done full reboot twice. Same.

  • pepioto

    abort food.c what shit of subrutine is?

  • pepioto, that is what I was wondering, and how to fix. I believe in installed both frash and another frash utility on my 3GS according to the instructions. and one time, it did, after a long wait, work. but not ‘abort food.c’ odd indeed.

  • mkabeer

    Hi,

    I am also getting same problem with my iphone 4…..

    ” _abort() food.c:43″

    many times restarted the phone but still no luck….

    Any one fine find the solution for this error message….

    Bye.

  • ega

    i have one solution for ipod 2g,i know,how to make install ignoring such depends,but i do not offer that it will work after installation.ok,first you must have terminal.then with ifunbox ,for example,upload deb installing archive in var/mobile/ and go in terminal and type su,then alpine,then dpkg -i –ignore-depends=gsc.armv7 Frash.deb archive will install.

    • Josee Cunha

      Ega how are you? I have an iPhone 3G running 4.1 and want to try your method, I have a MBP and would be Cyberducking the file. I do not understand your commands “dpkg -i –ignore-depends=gsc.armv7” depends or dependencies? I’m a bit confused so any help would be much appreciated. Then you wrote “Frash.deb archive will install.” does it do this automatically or is that part of the command. I tried adding it to the var>mobile>cydia>autoinstall and cydia keeps making me remove frash for some reason. Please help me I’m way lost on this one 🙁
      Thanks in advance for any help.

  • Nirjandada

    No solution at all…

  • Nirjandada

    No solution at all…Does anybody have??

    • Nirjandada, I have the same question. Here’s what I’m doing that helps me BETTER than Frash on my iPhone 3GS, though I must say I’d RATHER have someone tell us how to make Frash work on the 3GS. I downloaded (you guessed it from the iTunes store) the SkyFire web browser app for about 2.99 and it works fine in many flash contexts like Tangle.com and GodTube.com but not in all. But better than in NONE with abort and no replies. Hint in SkyFire; When the Frash window comes up, don’t click on it an wait another 15 seconds for a little window to appear under the Frash window, then click on that one.

  • Need help with stupid error code abort food and unexpected error

  • its worked.