iOS4 Pwned with UltraSn0w

The Dev Team updated the now famous UltraSn0w that allows to unlock baseband 04.26.08.

If you updated to iOS 4 while preserving your baseband, you can now download UltraSn0w from Cydia to unlock your iPhone so it works with any carrier.

In order to have UltraSn0w work for you, you need to:

  • have a jailbroken iPhone 3GS
  • be on baseband 04.26.08

More info on the iPhwn Wikee. [via French iPhone]

  • blah377

    Whew… I read unlock and was going to be SO pissed at them for releasing it… I think they should wait a month after the iphone 4 is released. This will let a ton of people have the phone and backup the infor for it BEFORE the unlock comes out, because my bet is once it’s in the wild, Apple will patch it within 1 week and then we’ll be in the same place and anyone who waited a minute to try and unlock theirs would be out of luck as they won’t be able to restore the old FW w/o having backed up their data.

    Stupid Apple…

  • Sotiris

    I agree. While I think its a great thing for 3GS owners right now they released it too soon. I hope that there isn’t going to be any problem.

  • iPhone 3GS

    Guys… this isn’t as big of a deal as you are making it out to be. UltraSn0w is for the original 3.0 baseband (04.26.08). They didn’t release an unlock for the latest 4.0 baseband yet so nothing new has been given to Apple.

    geez….

  • Lowb

    But is there any guide on how to actually update an 3GS to iOS4??

  • iPhone 3GS

    @Lowb

    just wait a few more days. Official 4.0 will be out Monday and the Dev Team will release the proper jailbreaking tools for it shortly after. It is better to keep your phone jailbroken now so you can just easily ride the jailbreak train into 4.0.