With the release of iPhone OS 3.1.3, a new MobileInstallation patch is needed. After looking around for a new MobileInstallation patch for iPhone 3.1.3, I was actually tipped that you can simply install the latest version of AppSync, which is compatible with 3.1.3

In order to install AppSync MobileInstallation for iPhone 3.1.3, you will first have to add the http://cydia.hackulo.us source, then search for AppSync. Any of the versions available will work, even the 3.0 version.