It seems that having an iPhone still running on OS 3.0 is getting more and more complicated. I’ve managed to avoid updating to the latest firmware for several reasons but it’s now catching up with me.

There are several applications I wanted to install from the App Store but it didn’t allow me to because it required at least firmware 3.1.

I haven’t updated since 3.0 because I didn’t want to lose my jailbreak/unlock. I realize that I could just use a custom cooked 3.1.2 firmware or even use BlackRa1n but I won’t for 3 reasons.

  1. I don’t want to use BlackRa1n. It reportedly sucks. Many were successful with it, but it seems even more people were having issues.
  2. I don’t want to use a cooked firmware right now because I am currently traveling around the world with a small netbook and I really don’t have the time for that.
  3. I believe iPhone OS 3.1.3 will be available in a month or so and I might just wait for the Dev Team to come up with a jailbreak/unlock for it and update at this time.

I tried installing FWchanger again to fake my firmware version but it doesn’t work very well, and it even messed up a few things on my iPhone. I guess I’ll have to live without these apps I wanted to install…

What firmware are you on?