The Dev Team updated UltraSn0w from 0.91 to 0.92 to fix the missing carrier logo. Those of you who unlocked using PwnageTool + UltraSn0w noticed the disappearance of the carrier logo. While this was just an “aesthetic bug”, the core functionality of UltraSn0w (the unlock) was not altered in any way.

A short update was given on the Dev Team blog earlier today:

Today we released an ultrasn0w update that fixes an issue for those running firmware 3.1.2 with the 04.26 baseband.  That specific combination resulted in a missing carrier name in the upper left-hand corner of your home screen.  Today’s ultrasn0w update from 0.91 to 0.92 fixes that problem (which was an important issue for roaming). You should see the update available if you have http://repo666.ultrasn0w.com as a Cydia source.  Enjoy!

According to AIS, the carrier logo has been fixed for the following countries: USA, Thailand, Austria, Trinidad, Germany, China, Kuwait, Serbia, Poland, France, Nigeria, Egypt, Pakistan, Ireland, UK, Turkey, Sweden, Switzerland, Malaysia, Hungary, The Netherlands, Bahamas, Jamaica, India, Israel, Belgium, Canada, Portugal, Denmark, Costa Rica, Italy, Chile and Argentina.

  • Dreadnutz

    Has anybody else had a problem since installing this where they get a message in Itunes saying that “the SSim inserted in this iphone does not appear to be valid” ?
    I never had this error until I did this upgrade now it comes up every time I try to sync and I don’t have an AT&T Sim on hand to get around it.