After jailbreaking using BlackRa1n, you may be facing an issue where you can’t access the root folder of your iPhone using tools such as iFunBox, DiskAid, and iPhoneBrowser. Some users also report issues when using WinterBoard. I said it and I’ll say it again, BlackRa1n is crappy. If you have the option, I recommend using PwnageTool instead. It is a much more reliable and stable jailbreak than BlackRa1n.

The problem comes from the fact that BlackRa1n doesn’t add the afc2 support to your iPhone that is necessary for iPhoneBrowser, iFunBox, and DiskAid to access the file system and allow the transfer of files such as Winterboard  themes, NES ROMs, etc…  to the iPhone. In other words, you can’t access the root partition of your drive.

To fix this annoying issue, simply install the afc2add patch from Cydia then reboot your iPhone. Done!

Have you had many issues with BlackRa1n? Let us know what you think about this jailbreak by leaving a comment below.

  • Chris

    I have not had 1 issue with winterboard or anything it works perfectly. I have a 3gs 32g. At least he can do what the dev team can’t right now. I would still be stuck if it wasn’t for blackra1n.

  • Kazyboy

    Hi, I jailbroke 2 iPhone 3 GS with BlackRa1n and they are working fine with NES Rom’s, WinSCP and WinterBoard… just let you know!
    Kazyboy from Switzerland

  • Navec245

    I have not had any other issue besides this one with blackra1n. And this simple hack fixes that issue.

    Don’t ha8e. Congratulate!

  • ILP

    I have an iPhone 3GS on 3.1.2 here, jB with blackra1n, and have never had any issues. Now that this has been mentioned though, I’ve installe the app needed. Still, I wouldn’t say blackra1n is shitty though…

  • Over

    I have not had any issue with blackra1n…. Because blackra1n doesnt work for my 3G… Hope dev team wount be lame and release pwngtool 4 win ASAP!!

  • Brian

    All I know is BR1 worked great for many while the same amount of people now have ‘bricked devices’.

    George is a very talented guy obviously, but BR1 should never have been put out in it’s current state. I see just as many people saying they have spent days on end and still have a bricked device then see people saying how wonderful it worked and they had no issues after the JB.

    He really should have thoroughly tested BR1 before releaing it….It doesnt matter who is first if it is buggy or doesnt work. better to be last and have something that is not buggy and actually works.

    Far too many people are having problems and I also feel as though George should have done a better job with the ‘instructions’. Supposed to be ’simple’ and for some it has been..but for just as many people BR1 has been a never ending nightmare.

    With all the bugs I would have expected George to realease something else after fixing all the bugs. very sorry he chose not to do this as this ’simplest JB ever’ as rendered many devices useless and has caused many to experience endless problems.

    In one of these other blogs there must be at least 100 different ways people posted to ‘get BR1 to work’. Yet Many tried EVERY METHOD posted and still have no success and only grief and a bricked device to show for their efforts. First to market is not always better and frankly it really is quite frustrating to try 100 different ways people claim they got BR1 to work, only to still not have it work or it ’sort of works’, meaning they got it JB’d but many things dont work, device crashes, apps crash…..many bugs experienced and etc…..

    I am one who has tried every method posted. No luck. So, right now, I am not really using my device as I will await a hopeful windows solution from the DEV TEAM.

    I did Donate to George and I dont regret doing so even though BR1 was a total failure for me…..It is working for others and I do like to ’support the cause’, but I truly do wish that he had spent more time ON BR1 before releasing it. It may work great for some, but just as many it is not working for or is causing alot of issues. If I only saw a few posts from people saying ‘it doesnt work’, I would take it as a grain of salt. But far too many people are having the same or similar issues and there are many of them, that it is quite obvious that BR1 is ‘buggy’ and should not have been released without further testing and patches to the bugs plugged in.

    Maybe we were all spoiled due to the ease of JB’ing in the past, but even so, BR1 should not have been released until it was thoroughly tested and all the bugs were worked out. BR1 worked for many, but for many others, it has been a total disaster and this is not how a proper jb program should work. Works for 50%, while not working for the other 50%. Then hundreds of ‘fixes’ posted by users not the developer, with most ‘fixes’ not working for the majority…….George is a genius, but I suspect he did this in a hurry to be first to market as well as so he could get back to his ‘real life’.

    George your efforts are greatly appreciated, but next time, dont release without further testing. We are all better off waiting for something that actually works without having to try 100’s of ‘workarounds’ then being first, but have it not work or cause repeated issues rendering the device useless.

  • Over

    amen 😉

  • straegle

    What about the problem with delayed voicemails? I jailbroke my 3g on 3.1.2 with blackra1n and my voicemail works. But then i jailbroke a 2g on 3.1.2 with blackra1n and voicemail doesnt work. Have to call to retrieve left voicemails.
    Anyone know how to fix this problem?

  • jakobo

    For me blackra1n worked perfectly (iPhone 3g s 3.1.2 os) and I have not had any issues yet.

  • Joe

    UK iphone 3Gs 3.1.2 just JB by blackra1n, and have one big problem….nearly all soft and games do not have sound! But phone calls, youtube and radio software’s sound is fine. Anyone know how to fix this problem?

  • David

    Used black rain and no problems so far. 3GS 32gb, OS 3.1.2.

  • tester13

    I have tried BR on 3 iPhones. It has worked on one of them. I have NO idea why it worked on that one and not the others. Completely random… If it at least had some way to identify errors I’d be happy… Oh well, waiting for a legitimate windows jailbreaking application.

  • Rn3sto

    Hey man blackra1n sucks!!!
    For one part, I gotta admit it saved me from not been able to install 3rd party apps but it is definetely worst than redsn0w.
    First, I couldn’t get to jailbreak my iPhone, so I watched some vids on YouTube and after several atemptings I managed to get the blackra1in logo onto my screen and working.
    Then, after installing cydia (and just cydia) I wanted to add some cydia apps, so I did. And when I respring I noticed Cydia was gone. I found cydia and other 3rd party apps through spotlight and seemed to be working ok but then Cydia crashed for ever and now, I am unable to add any source…. to top it off I don’t even have the sources that usually come with the iPhone, so in oyher words I am unable to use cydia.
    Luckily I installed what I wanted (AppSync) on time but still I’m wondering how come!
    Am I the only one with this problem or sort off???

  • Rn3sto

    By the way, I have an iPhone 3G

  • weez

    Also have a 3GS 32gb 3.1.2, and it worked perfectly, with no special steps or measures taken. I’m guessing it works fine on that particular model, and has trouble with others. Which is good because people buying a new 3GS wouldn’t have had many options otherwise…

  • Cayman (Attila)

    I have 3gs with no problems too.
    There is only one issue that i cant fix, and cannot understand.
    I want to use custom keyboard, ive tried to install many of them, and neither worked.
    Anyone got any idead how i could solve this issue? 🙂

  • Clive

    no problem at all (just locked 🙂

  • casey

    using balckra1n was my first jail break
    easy to use done in under 10min no problems so far

  • ruffnek

    Is there another JB solution that will run on Windows?

  • Brian

    This blog is very typical..We have some posting that BR1 worked great and they are experiencing no problems, while the same amount of people are saying it did not work, or it did, but nothing but one problem after another keeps arising.

    This is exactly why I said that BR1 should NOT have been released until further testing and the bulk of the bugs were patched.

    It is nuts that BR1 appears to work for one person but not the other, when both are using the same device and the person it is not working for has tried the 100+ posted ‘solutions’ to make it work, but it still doesnt.

    Why put out a program this fast and claim it is is the simplest JB ever and works for all devices, when it is readily apparent that for some, yes it was simple, fast and it worked, but there are just as many people sitting here with BRICKED devices with no jb or a JB, but cant really use the device as the bugs render it useless?

    Why DEV team is not and has not yet come up with a viable windows based JB, is a bit odd. I have to question if they have not been able to release a solid (works as it is supposed to work) win version by now, will they ever? They seem to care far more to get things working for the MAC while PC users are left dangling wondering what is going on.

    But hey, these guys do this for free so I guess beggers cant be choosy, but I fail to understand why DEVTEAM refuses to say whether a pc version that works is forthcoming. I could care less about ETA’s, but I really fail to see why DEV refuses to keep people updated at least as to whether something is being worked on for us PC users. First I heard they were but no eta’s would be given. Fine as I am not looking for an eta. But now they seem to be very tightlipped and anybody even asking if they have a PC version coming gets flamed bigtime by other blog posters and even the moderators of the blog.

    That blog is becoming a Jerry Springer Episode. If people cant answer a question or are only going to answer with flames, insults and rude remarks, then just shut the heck up. People dont read that blog to see a legit question asked but then wade thru countless replies that have no answers, only insults to the OP. It is these people who dont know that if you dont have anything useful to say or have a legit answer then it is best to shut up as responding 30 times with insults and non pertinent information to every question asked has made it almost impossible to get any real info after reading for hours.

    So, to sum it up….BR1 should not have been released since it is pretty obvious it is causing many, many problems for many, many people and no JB program should be called the simplest ever when it MAY be simple for SOME, but others spend 24/7 trying to get it to work with no luck. Furthermore, the ‘simplest JB ever’ should not require a zillion people to try ‘solutions’ posted by other users..the developer is the one to do this…..how many people tried every solution posted by others with no luck and only wasted time and the end result is a device that does not work? Where is George to fix these issues or at least address them? Why would he release BR1 claiming it is simplest ever, and is obviously aware of the many issues it has, but he has not done anything about it?

    Lastly, I think the MODS on the DEV BLOG should start to ban people responding to others with useless replies. Then again, the mods over there appear to take part in flaming others and insulting others, so it is no surprise that the blog has become the latest Jerry Springer episode and it is no surprise I have heard rumblings about legal action being taken. Finally, the DEV team really should at least update people a bit better. I know they have no obligation to do so but they must know the large amount of people that rely on them and leaving people dangling in the dark is just not good.

    For me, having a non JB’d device is worthless. If I cant JB it, the device is not worth $50 to me. But, I am beginning to think that having a JB’d device is not worth having to go thru this evertime Apple releases an update and as I have blogged before, APPLE is working hard to cause issues for the hackers and those that use unlocked and jb’d devices and apple will only continue to up the ante in this ‘war’. Which means, all future unlocks and jb’s will only get more complicated and create more issues for both the hackers and the users.

    I for one, will not go thru this again. It simply is not worth it. I have a life as I suspect others do as well and I’ll be damned if I am going to go thru this everytime time apple puts out another update.

    The days of an easy and carefree unlock/jb are over. We have others that work on unlocks and JB’s but DEV is really the only one who can be counted on and they are making it pretty clear that they are having issues. The big one is the unlocking once baseband has been upgraded. They admit there may never be a fix for this…but what really has me down on DEV team and what has me thinking these guys cannot be relied on any longer is the fact that they are ignoring exploits for PC users and I know there are many that swear by their MAC’s, but the fact is, far more people are on PC’s then are on macs and no, most do not want to add MAC OS to their PC’s……DEV is getting beaten by Apple and Apple will only continue to make it harder and harder and now DEV has given up on exploits for PC users, or at the least, they sure dont care too much about PC users…..when do they plan to release something for PC users..after Apple puts out 3.1.3 or 4.0, which will likely render whatever they come out with as useless?!

    Looks like Apple is winning and DEV TEAM is useless unless you own a mac and even if you do have a mac, it still looks like Apple is going to put DEV team out of biz eventually, if not sooner then we think.

  • Rn3sto

    @Brian
    Wow man, or you have no life or you are in love with this blog!! 😮
    The world’s largest comment man!

  • Lou

    iPod Touch 2G 16GB – OS 3.1.2 – Blackra1n not working.
    I am using Linux OS (Ubuntu 9.04) and I am very disappointed about the Support Apple has for Linux Users. For Apple the Computer World ends with OSX and Windows. Did they forgot that OSX is build on Linux ? How hard can it be to support the growing Fan Church of LInux Users ? Running iTunes in a Virtual Box is not that great – specially if you have an older Laptop like I have (AMD X64 1.6GHz, 1GB RAM). Jailbreaking seems the only way to do the basic stuff with iPod/iPhone. Sure, I can copy Pictures out of the box (great since the iTouch has no Camera nor Video). Even copy Music from/to the Device is a hassle – and the iTouch is basically made for that – Video the same.
    So after all Blackra1n is not working in my virtual box. Since the OSX Version is out it should be not a big problem to release a Linux Version !?!?
    The Donate Button on Blackra1n is bigger than the Download button and Support is only from Users like you. That said

  • Brian

    Rn3sto said:
    @Brian
    Wow man, or you have no life or you are in love with this blog!!
    The world’s largest comment man!
    ========================================
    At least my post was somewhat useful/on topic. Not to be rude, but it is people like you who find the need to reply with nothing useful(as I am doing now ) that makes people have to read 500 posts to find 50 useful ones.

    May I make a suggestion? If you have no answers, solutions or on topic comments, dont post and save others the time in having to read useless posts (like this one ;>)….)

  • It’s was fast but 2 issues the biggest issue is can’t run my T-Mobile sim and 2nd ALL my apps that I downloaded from Apple app store crashes even after reinstalling app. But apps I installed using installous is fine.

    I’ll have to re-jailbreak my phone with non blackra1n jailbreak

  • Dyl@n

    i tried this and my winterboard STILL doesn’t work, but i cant use pwnage tool because i didn’t jailbreak my ipod touch 2g until after i accidentally upgraded to 3.1.2. Help!!!

  • Mig

    I think this blog is crappy.. not blackra1n

    afc2 support is not standard and a pure JB tool should not install it, leaving the user the choice. And if the user wants it’s just a couple of clicks to install.
    Simple and easy

    PS the suggestion of using PwnageTool is not wise for 3GS owners that doesn’t need unlock.. better blackra1n..

  • Nick

    Have Jailbreaked my iPhone 3GS 3.1.2 with Blackra1n and works fine until i download an app like winterboard , themes etc. The iphone asks to be rebooted in doing so re-enters reovery mode where the only solution is to Restore the Iphone to factory settings. Thereby erasing blackra1n, cydia etc and back to square one. Is there a way to fix this issue. Any help would be appreciated.

  • connor thorpe

    iv got blackra1n on my phone and when i got to use ifunboxn it wont let me look at my library so i cant put themes across can some one plz help me >? thank you othere then tht winterbord and evry thing ells works fine thank fuck for jailebating x

  • Ivo

    iPhone 3GS 3.1.2 work fine
    Croatia

  • Spooky

    Thanks so much…. I thought I had to throw DiskAid in the bin (either that or the phone!), how I can use it again!!!

  • Fib

    Nick said:
    Have Jailbreaked my iPhone 3GS 3.1.2 with Blackra1n and works fine until i download an app like winterboard , themes etc. The iphone asks to be rebooted in doing so re-enters reovery mode where the only solution is to Restore the Iphone to factory settings. Thereby erasing blackra1n, cydia etc and back to square one. Is there a way to fix this issue. Any help would be appreciated.
    ———————————————————————————-‘

    I Have the same problem Nick. Or.. I think mine is far worse, it seems I can’t install any apps at all, everytime i try I end up with the phone needed to be Restored in iTunes.

    Any ideas?

  • steve

    Nick said:
    Have Jailbreaked my iPhone 3GS 3.1.2 with Blackra1n and works fine until i download an app like winterboard , themes etc. The iphone asks to be rebooted in doing so re-enters reovery mode where the only solution is to Restore the Iphone to factory settings. Thereby erasing blackra1n, cydia etc and back to square one. Is there a way to fix this issue. Any help would be appreciated.

    u have a new model from Apple, rite? it’s been implement by apple, such a anti-Jailbreak-Thing inside, but still it can be jailbreaks.
    so the solution here is just RE-JAILBREAK with Blackrain…SOLVED. (Restore to Factory Setting is NOT NEEDED)
    and After that…do not reboot ur device if not so urgent to, or getting off cause by low batt…because those can bring ur device into Recovery-Mode again….then u just have to RE-JAILBREAK again…etc.

    i still dont know if this issued has been fix permanently out there…is it??

    Fib said:
    I Have the same problem Nick. Or.. I think mine is far worse, it seems I can’t install any apps at all, everytime i try I end up with the phone needed to be Restored in iTunes.

    Any ideas?

    FIB: u must install AppSync from cydia first before u can download and install any applications.

    hope this helps

  • vic

    thank you for ths page i couldnt figure out why i could access my root folder THANK YOU !!

  • Whisky0540

    I have jailbreaked my Iphone 3gs using blackrain and tried downloading winterboard after it installed i had to reboot my phone then restore it using I tunes, i had the same issue after trying to install yourtube anyone got any advice as to what the fcuk is going on ????

  • Tech

    Whoever says that there blackra1ned ipnone works perfectly is an idiot im an IT tech at an office and do freelance work for alot of different companies one of those is a phone company that i fix phones and unlock such as iphones first blackra1n came with no warning that it woud brick, then he finally came with a unlock good job but only fixed half an issue. all iphones still have wifi, youtube, mms, thethering, iphonebrowser, issues. iphonebrowser does work with winterboard but doest show root folder for you noobs out there. now when i jailbreak a phone i have a list of 6 things i have to also install (things that good ol george forgot in blackra1n) to make it fully functional for the user its not even worth the money to do it anymore. so again for you noobs who know nothing about what im talking about you should really not try to smash on a guy whos giving us advice on a fix that your best friend george forgot he simply saying do a better job next time im sure the money n termoil george caused for about a month wasted worth him being first a such a shitty jailbreak. just sayin

  • Shawn

    Well.. I didnt have a problem with my first phone.. now whenever I install winterboard on my phone after using blackra1n.. it sends my phone into a recovery status and I lose all my data.. I came across this post after about 6 times of rebooting my phone.. I was mad because I lost all my pictures that I took today of my accident and I might need that whenever it was time to prove who was at fault. So I am very upset right with how it worked out for me. Although I must say it is one of the easiest unlocks for the iphone to date, I just wish it were a more solid one as well.

  • Shawn

    Okay! after several trial and error runs.. I have come to the conclusion that the issue with the iphone going into recovery mode happens everytime the phone reboots.. because this happened when i installed winterboard AND the AFC2 hack.. so after trying several times.. i finally found a way that worked for me.. After unlocking and jailbreaking the phone.. I get to the point where i install winterboard.. phone reboots and once again it asks you to restore using itunes.. now heres where i couldve gone either way here.. im not exactly sure what happened.. but i either took out the sim card or threw in an old tmobile one before connecting it back with the computer.. now when i plug it in.. i see georges face pop up on my phone.. so i wait.. and sure enough i get to the regular screen before i even have to restore my phone.. on this trial and error i also lost connection to my wifi so i did network reset using the same method.. and it worked again.. this time saying i would need to insert a sim card without a hold or something.. so i put in the att sim card and look around.. and there it was winterboard app.. i then became cautious and took out the att sim and am currently setting up my entire phone to my liking using only WiFi.. but I think I’m just being too precautious.. so pretty much try removing the sim card after the phone reboots itself before plugging in into your computer.. Let me know if this helps out some of you.. so I know it is a definite method.. yes it is tedious but i cant stand the standard iphone interface.. so it might be worth your time as well..

  • Shawn

    im not sure if this also plays a factor in my prior post.. but after i jailbroke was finished.. i left the blackra1n box out on the desktop.. its still currently showing “done, wait for reboot”.. just adding that in just in case..

  • Jack

    Hey thanks!

  • Ruby

    I JB my device with blackrain… Everything worked fine for a while. Until about two weeks later. It just gets stuck on the apple screen and I have to restore my phone everytime. This last time, I decided not to install winterboard. I haven’t had a problem since. Just sucks because a major reason for JBing was to customize thngs. Everything is whacked out. Help….

  • Andreas

    blackra1n sucksssssssss it got my phone jailbroken but now i miss my calls and get them after 4 hours the cydia app is not working and I cannot access my phone through SSH to fix it. George sucks and blackra1n blows FU DEAD SCUM

  • Miles

    I have a 2g iphone and jbroke it with blackra1n. I had the youtube issue and installed the pushfix app, and rebooted the phone and it was fine. I also had the issue of viewing root and had to install another app from cydia to make the fix to view from iphonebrowser app. Other than that, it is still definately worth checking out and seeing if it works for u.

    good luck.

  • Loke

    For all those talking about rebooting devices and having reset your iPhone to factory settings.

    Apple fixed a weakness in their latest update to 3.1.2 so if you have updated to 3.1.2 or bought a phone after the fix. You wont be able to jailbreak freely. The only jailbreak working for 3.1.2 afaik is the Blackra1n Tethered jailbreak.

    Tethered jailbreak means that you have to Plug your iphone into the PC while blackra1n is running when you reboot your device. So for instance installing winterboard, or running out of battery. You will need to restart your device while plugged in. This is a hassle I know, but it’s the only way for those who have updated to the latest baseband.

    If you have a PRE 3.1.2 iPhone DO NOT use iTunes to update, get pwnagetool and update to 3.1.2 through the tool, and you will KEEP your old baseband, and you can have a fully jailbroken iPhone.

    Rumour is that there will be a jailbreak for 3.1.2 but not untill Apple release their fourth generation phone. till then, we have to make do with a tethered jailbrea.

  • Lala

    I used ifunbox to send stuff to my phone and now i cant c them and the memory they took up is gone. while i love my iphone is there any1 who can save or atleast help prolong its life w/ me by telling me how to get the hidden stuff off w/out restoring???

    please email assistance thanks!

  • Aeby

    thank u so much 4 solving my prb………………i was unable 2 access root partition of my iphone although i hav already jailed broken it………………..thanks again

  • jose

    i use br1 work good for me my only problem is my pc don show my iphone on my computer.this hapen after i jailbroke the phone,i tune reconaize it my iphone is on device manager, but i cannot make it to cameup on my computer.any one know how to fix it.thankyou.

  • Lelio

    i wouldnt say Blackrain is crappy. is easy and simple to use for newbie people, the only problem i found was that i couldnt access the root directory, but thanks to you thats no longer a problem.
    peace out.

  • loganfynne

    Thank you so much. But Jay Freeman is still a genius.

  • Pissed Off

    NOV 2010 : DiskAid 4.11 has some serious bugs.

    I was in the process of RENAMING a FILE (an MP3). As I was typing the new name, I wanted to remove an extra character .. so I pressed DELETE on the keyboard. DiskAid then RENAMED the entire FOLDER (where the file being renamed resided) which resulted in the folder’s new name being the SAME as the file I was trying to rename (the partial name at the moment I pressed delete key).

    After I realized what happened – a major screw-up by Digidna.net), I renamed the folder back to its original name. When I opened the folder this time, the file I was trying to rename was DELETED! How did this happen?!

    And there’s NO “are you sure” confirmation prompt .. NOR an undo function!!

    I am very dismayed. What, if any, type of QA (quality assurance) testing is the developer performing before this stuff is released to the public? This mistakes / bugs are costly to us consumers.

  • I have installed afc2add but I still can’t find folders like Coreservice…What should I do???????