Since firmware 2.2.1 was released yesterday, a lot of concerns were raised whether or not you should update. The quick answer is NO, do not update if you care about your jailbreak or your unlock. MuscleNerd released a video on Qik giving us more info about the situation. Below are notes from the video.

About the iPhone 3G:

If you use YellowSn0w, you do not want to update to 2.2.1 as it will remove the possibility to install it. The only way you could do it is my installing a custom firmware that doesn’t update the baseband. PwnageTool and QuickPwn do just that but they haven’t been updated for 2.2.1 yet so wait for them to come out.

About the iPod Touch 2G:

The 2.2.1 firmware doesn’t affect your ability to jailbreak your iPod Touch 2G. It didn’t remove the ability for the Dev Team to do a tethered jailbreak. The Dev Team is still looking for an exploit to allow an untethered jailbreak. In other words, hang in there, they are working on it.

About iPhone 2G and iPod Touch 1st Gen:

2.2.1 doesn’t affect your ability to jailbreak or unlock but again, wait for an updated version of QuickPwn and PwnageTool to do that.

As usual, I will report to you as the news come about 2.2.1 and jailbreaking/unlocking so you may want to subscribe to the RSS feed to be notified in time.

  • Curt

    just my luck, picked up the iphone yesterday with the update already done… painful…

  • Steve

    Guess who tried to jailbreak from 2.0 to 2.2 the day this was released ?? Aaaggghhhhh 🙂

  • Pingback: Sorta QuickPWN 2.2.1 Is Out. I Say Stay Away()

  • Tiny

    So I updated to 2.2.1 (didn’t see your warning until I had upgraded!) Can I restore to 2.2?